On Sun, Jul 16, 2006 at 03:12:49PM +1000, Rob Hurle wrote:
>       I'm trying to set up FreeBSD on my box, which has an Intel
> D945GNT motherboard, two 3.2GHz processors, 1GB memory.  The system
> installs OK and I've been able to use cvsup to upgrade everything,
> remake the kernel (for SMP), build OpenOffice.org 2.0.2 KDE 3.5.

Just to clarify, are those processors amd64/em64, or ia32?  Are
you running a 32-bit or 64-bit system on them?  Aah.  I see from
your uname, below, that you're running i386 code.  That should
remove a few potential pitfalls.

> However, three problems remain unsolved in spite of all of these
> things:
> 1.  Only one processor seems to be used.  The output from top -S is:
>    11 root          1 171   52     0K     8K CPU1   0   0:00 99.02% idle: cpu1
>    12 root          1 171   52     0K     8K RUN    0 139:40 98.34% idle: cpu0

It seems to me that the FreeBSD scheduler is pretty keen on
processor affinity, which is a good thing.  My AMD-X2 dual core
system has been up a good deal longer than yours, but the idle
times are still fairly different:

root      12 99.0  0.0     0    16  ??  RL    8Jul06 9797:24.05 [idle: cpu0]
root      11 98.5  0.0     0    16  ??  RL    8Jul06 11206:02.27 [idle: cpu1]

Do you get any activity on the other CPU if you do a buildworld
with make -j4 or so?

> 2.  KDE 3.5 does not like to run any screensaver.  They all run OK on
> test, and if I run the actual programs themselves, there is no
> problem.  However, KDE will not start them up automatically.

I'm afraid I run a GNOME system, so I can't help with that
problem.  The screen saver doesn't seem to have any trouble
starting under GNOME, but I haven't been able to get it to do
the DPMS monitor power-down yet.  Still investigating that.

> 3.  OpenOffice.org does not like any of the files produced from
> anywhere else.  I have stuff written in StarOffice 5.2 and in MS Word,
> but none of these will open.  Even stuff written using OpenOffice.org
> 2 on a MS system is not acceptable.  The error is always "General I/O
> Error".  OpenOffice will read files that it has written quite OK and
> permissions, ownership, etc all seem to be OK.

I believe that most of the OOo file import functionality is
provided by Java modules, and it will successfully build without
this functionality if you don't have or don't want to run Java.
Do you have a working native Java implementation?  You might
need to get Java going before building (or re-building) OOo.

>       Neither the KDE nor the OpenOffice problem has altered by
> upgrading these two systems and the SMP problem is also the same as
> with the GENERIC kernel.  uname -a gives:
> FreeBSD grandpa.connect-a.com.au 6.1-RELEASE-p3 FreeBSD 6.1-RELEASE-p3 #0: 
> Sat Jul 15 16:46:44 EST 2006     [EMAIL 
> PROTECTED]:/usr/src/sys/i386/compile/SMP  i386

freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to