I run FreeBSD 6.1-RELEASE. About a week ago, I made the egregious
mistake of deleting the '/var/db/pkg' directory, so I had no choice but
to portmanager everything back (I build from ports). This wasn't
actually so bad since I didn't have CXXFLAGS configured the first time,
so at least now I would get optimized binaries (as an aside,  are '-O9
-march=athlon-xp -mfpmath=sse' the best options for a Duron(TM)

But now, I am having major problems starting KDE (3.5.3):
1) When I run 'startx' from the shell, the screen "clicks" into video
mode, I see the X black-and-white wallpaper for an instant, then it
turns black with the 'X'-mouse (it's responsive), and stays that way
forever, until I kill X. I captured the tty output: 

xauth:  creating new authority file /root/.serverauth.7480
/usr/X11R6/bin/xauth: (argv):1:  bad display name "Compy:0" in "list"
/usr/X11R6/bin/xauth: (stdin):1:  bad display name "Compy:0" in "add"

X Window System Version 6.9.0
Release Date: 21 December 2005
X Protocol Version 11, Revision 0, Release 6.9
Build Operating System: FreeBSD 6.1 i386 [ELF] 
Current Operating System: FreeBSD Compy 6.1-RELEASE FreeBSD 6.1-RELEASE
#1: Tue Jul  4 20:39:59 PDT 2006    
[EMAIL PROTECTED]:/usr/src/sys/i386/compile/MYKERNEL i386
Build Date: 14 July 2006
        Before reporting problems, check http://wiki.X.Org
        to make sure that 
you have the latest version.
Module Loader present
Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Mon Jul 17 19:20:23 2006
(==) Using config file: "/etc/X11/xorg.conf"
Warning: kbuildsycoca is unable to register with DCOP.
kbuildsycoca running...
# N.B. this is where the screen switches. The following lines come
# only after killing X.
kdeinit: Shutting down running client.
FreeFontPath: FPE "/usr/X11R6/lib/X11/fonts/misc/" refcount is 2,
should be 1; fixing.
/usr/X11R6/bin/xinit:  connection to X server lost.
/usr/X11R6/bin/xauth: (argv):1:  bad display name "Compy:0" in "remove"
xset:  unable to open display ":0"
startkde: Starting up...
kdeinit: Shutting down running client.
ICE default IO error handler doing an exit(), pid = 7531, errno = 22
startkde: Could not start kdeinit. Check your installation.
startkde: Shutting down...
unix_connect: can't connect to server
startkde: Running shutdown scripts...
startkde: Done.

2) I can start X with 'xinit', and this is fine. I can then issue
'kdeinit', which gives a ton of "kbuildsycoca: WARNING: foo specifies
undefined mimetype/servicetype bar" lines. Then I can do 'kwrapper
ksmserver&', and that'll give me the familiar window frames, but not
any aspect of the desktop.

Does anyone have any advice?

Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to