On Thu, 20 Jul 2006 00:52:16 -0700
Andriy Babiy <[EMAIL PROTECTED]> wrote:

> Hi all,
> I installed all the libraries mentioned on k3b.org, including mandatory and 
> optional (actually, excluding two of the optional libraries - libmusicbrainz 
> and hal). I used the latest versions of all the libraries, and k3b as well.
> FreeBSD version 6.1.
> "./configure" runs without error messages.
> But when I run "make", it fails with the error message as follows:
> make  all-recursive
> Making all in doc
> Making all in libk3bdevice
> /usr/local/bin/bash ../libtool --silent --mode=link --tag=CXX g++  
> -Wno-long-long -Wundef -Wall -W -Wpointer-arith -O2 -Wno-non-virtual-dtor 
> -fno-exceptions -fno-check-new -fno-common -fpermissive    -o libk3bdevice.la 
> -rpath /usr/local/lib -L/usr/local/lib -L/usr/X11R6/lib -version-info 2:1:0 
> -no-undefined k3bdevice.lo  k3bdevice_mmc.lo k3bscsicommand.lo  k3btrack.lo 
> k3btoc.lo k3bdevicemanager.lo  k3bmsf.lo k3bdiskinfo.lo k3bdeviceglobals.lo  
> k3bcrc.lo k3bcdtext.lo -lkio  -lcam  -lm -L/usr/local/lib -L/usr/X11R6/lib
> libtool: link: cannot find the library `'
> *** Error code 1
> Stop in...
> The name of the library, which cannot be found, appears empty in the message.
> Maybe, I should try some configuration options?
> If someone here faced a similar problem and solved it,

Methinks someone did, since it's in the ports collection
(at /usr/ports/sysutils/k3b).

> or just know how to approach the problem, their advice would be highly 
> appreciated.

Is there a reason you're compiling it manually? If so, it may
be worth your while examining how it's done in ports and
applying a similar approach.

> I can provide all the results shown on the screen during "configure" and 
> "make", if it is useful for targeting the problem.
> Many thanks to all in advance.
> Andriy
Nick Withers
Web: http://www.nickwithers.com
Mobile: +61 414 397 446
freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to