List,

On an old Redhat box (address 172.17.0.18), I'm trying to mount an NFS export from a FreeBSD (5.2.1-RELEASE) box. Both machines are on the same network segment, and neither have any onboard firewalling rules.


I run the following command (on the redhat, bechet is the FreeBSD box):

  mount -v -t nfs -s -o ro,soft,intr bechet:/home/ftp/pub/mirror /net/mir

And I get back:

  mount: RPC: Remote system error - Connection refused

On the FreeBSD box, /etc/exports contains

  /home/ftp/pub/mirror 172.17.0.18

rpcinfo -p produces:

   program vers proto   port  service
    100000    4 local    111  rpcbind
    100000    3 local    111  rpcbind
    100000    2 local    111  rpcbind

/etc/hosts.deny is empty, and /etc/hosts.allow contains

  ALL: ALL : allow

The relevant processes on the FreeBSD box are

   95  ??  IL     0:00.00  (nfsiod 0)
   96  ??  IL     0:00.00  (nfsiod 1)
   97  ??  IL     0:00.00  (nfsiod 2)
   98  ??  IL     0:00.00  (nfsiod 3)
  343  ??  Is     0:04.41 /usr/sbin/rpcbind
  425  ??  Is     0:04.61 /usr/sbin/rpc.statd
11373  ??  Is     0:00.01 /usr/sbin/mountd -r
88497  ??  Is     0:00.05 nfsd: master (nfsd)
88498  ??  I      0:00.00 nfsd: server (nfsd)
88499  ??  I      0:00.00 nfsd: server (nfsd)
88500  ??  I      0:00.00 nfsd: server (nfsd)
88501  ??  I      0:00.00 nfsd: server (nfsd)

(I understand, from reading the handbook, that I should be using rpcbind rather than portmap). This server has been an NFS server in the past, so I know it worked at some point. I'm not sure if I'm missing a daemon in the mix, or if there's something else I've overlooked.

Any clues will be most graciously received :)

Thanks,
David


--
Much of the propaganda that passes for news in our own society is given to immobilising and pacifying people and diverting them from the idea that they can confront power. -- John Pilger

_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to