David Kelly wrote:
On Thu, Jul 20, 2006 at 05:16:16PM +0200, David Landgren wrote:
List,

On an old Redhat box (address 172.17.0.18), I'm trying to mount an NFS export from a FreeBSD (5.2.1-RELEASE) box. Both machines are on the same network segment, and neither have any onboard firewalling rules.

[...]

(I understand, from reading the handbook, that I should be using rpcbind rather than portmap). This server has been an NFS server in the past, so I know it worked at some point. I'm not sure if I'm missing a daemon in the mix, or if there's something else I've overlooked.

Any clues will be most graciously received :)

For starters try "showmount -e the.freebsd.ip.address" on the Linux box
to see if the Linux box sees the NFS daemons on the FreeBSD machine.

Hrm.

# showmount -e 172.17.0.21
mount clntudp_create: RPC: Port mapper failure - RPC: Unable to receive

mountd needs to be running on the FreeBSD host (apparently yours is
running). When /etc/exports changes mountd needs to be informed:
        kill -s HUP `cat /var/run/mountd.pid`

Yup, know about that.

Also at least in the past Linux distributions defaulted NFS to
non-reserved ports. Your Linux may not be talking to the same ports as
the FreeBSD machine is listening.

Let's have a look...

# nmap 172.17.0.21

Starting nmap V. 3.00 ( www.insecure.org/nmap/ )
Interesting ports on bechet.bpinet.com (172.17.0.21):
(The 1584 ports scanned but not shown below are in state: closed)
Port       State       Service
21/tcp     open        ftp
22/tcp     open        ssh
25/tcp     open        smtp
37/tcp     open        time
80/tcp     open        http
199/tcp    open        smux
443/tcp    open        https
801/tcp    open        device
901/tcp    open        samba-swat
1011/tcp   open        unknown
1020/tcp   open        unknown
2049/tcp   open        nfs
3306/tcp   open        mysql
5308/tcp   open        cfengine
5432/tcp   open        postgres
5999/tcp   open        ncd-conf
8080/tcp   open        http-proxy

My god there's a lot of crap on that box! Still, looks like NFS is running. And according to the man page of the linux box:

port=n
The  numeric  value  of  the  port to connect to the NFS
server on.  If the port number is 0 (the  default)  then
query  the  remote host's portmapper for the port number
to use.  If the remote host√Ęs NFS daemon is  not  regis-
tered  with its portmapper, the standard NFS port number
2049 is used instead.

So that sounds about right. I tried adding port=2049 explictly to the mount command, but same error: "Connection refused"

Well, thanks for your help. Beats me what I've done wrong.

Thanks,
David

--
Much of the propaganda that passes for news in our own society is given to immobilising and pacifying people and diverting them from the idea that they can confront power. -- John Pilger


_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to