Hello Guys,

 now im so missed with my wireless settings,
 I tried almost everything everyone has suggested.
 output of kldstat
# kldstat
Id Refs Address    Size     Name
1   20 0xc0400000 69605c   kernel
2    1 0xc0a97000 fa20     if_ath.ko
3    3 0xc0aa7000 3015c    ath_hal.ko
4    2 0xc0ad8000 3fbc     ath_rate.ko
5    1 0xc0adc000 58554    acpi.ko
6    1 0xc5080000 16000    linux.ko
7    1 0xc6d61000 1d2000   w39n51_sys.ko
8    1 0xc6f33000 b000     if_ndis.ko
9    2 0xc6f3e000 13000    ndis.ko

loader.conf has the follow

if_ath_load="YES"

I even tried uploaded the .inf and .sys files and did the
ndiscvt -i W32DRIVER.INF -s W32DRIVER.SYS -o ndis_driver_data.h
then installed the driver module,
nothing isthere!!

I built the kernel with almost all the drivers i saw anywhere.. and still ifconfig -a showing
fwe0: flags=108802<BROADCAST,SIMPLEX,MULTICAST,NEEDSGIANT> mtu 1500
       options=8<VLAN_MTU>
       ether 62:3f:02:6c:41:84
       ch 1 dma -1
fxp0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> mtu 1500
       options=8<VLAN_MTU>
       inet6 fe80::216:d4ff:fe01:617e%fxp0 prefixlen 64 scopeid 0x2
       inet 192.168.0.14 netmask 0xffffff00 broadcast 192.168.0.255
       ether 00:16:d4:01:61:7e
       media: Ethernet autoselect (100baseTX <full-duplex>)
       status: active
lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
       inet6 ::1 prefixlen 128
       inet6 fe80::1%lo0 prefixlen 64 scopeid 0x3
       inet 127.0.0.1 netmask 0xff000000

ALso i tried the ndisgen way, to convert, and it built the driver as w39n51_sys.ko and i kldloaded

# kldload /usr/home/admin/w39n51_sys.ko
after issuing this command, no devices showedup in ifconfig -a and
this is the result in /var/log/messages

kernel: ndis0: <Intel(R) PRO/Wireless 3945ABG Network Connection> mem 0xd2100000-0xd2100fff irq 18 at device 0.0 on pci6
kernel: ndis0: couldn't map memory
kernel: device_attach: ndis0 attach returned 6


There is no wireless devices showing..! :(
Again its HP pavilion dv5178us
the wireless is a builtin, and its Broadcom Corp HP Integrated module.

Im attached a file of my dmesg output,
I wish someone have any solution for this..

Note:
I googled... and found nothing, i eat the words in
http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/network-wireless.
and there is no case like this:)

-Marwan
> > Hello gurus,
> >
> > Can someone help me setting up my wireless device on my laptop
> > im on 6.1R, I tried to do as instructed on handbook, but no luck.
> > My laptop suppose to be the client, and i have a netgear wireless modem
> > router up and running.
> > How to make the freebsd see the router have the ip, and make the device
> > up?
> >
> > from dmesg
> > ugen0: Broadcom Corp HP Integrated Module
>
> ugen is the generic usb device driver that gets attached if a specific
> driver for the device is not available. I don't think you will be able
> to do anything useful with it (it seems to be intended more for
> developers to use while experimenting with a device).
>
> There is a tool called ndiscvt that will take a Windows NDIS device
> driver and wrap it up in an interface that allows it to be used as a
> FreeBSD driver. Most likely, you will need to do that to get your
> interface working. Instructions are in section 27.3.3.6.3 of the
> FreeBSD Handbook (buried in one of the sections someone has already
> mentioned:
> http://www.freebsd.org/doc/en_US.ISO8859-1/books/handbook/network-wireless.
>html

You hint at this below, but ndiscvt should no longer be run by the user.

> In 6.1 there is a script called ndisgen that automates the process
> described in the Handbook. You will probably find it much easier to
> read its man page and use it instead of using ndiscvt directly. The
> instructions amount to "become root, run ndisgen, do what it says."

Unfortunately, the developer of the ndis drive has specifically stated that
USB is not (yet) supported.

> Once you have successfully built and loaded the NDIS driver, it will
> by default show up as ndis0 when you do an ifconfig. Once that
> happens, the rest should be easy.

JN
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

_________________________________________________________________
Express yourself instantly with MSN Messenger! Download today it's FREE! http://messenger.msn.click-url.com/go/onm00200471ave/direct/01/
# dmesg
Copyright (c) 1992-2006 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
       The Regents of the University of California. All rights reserved.
FreeBSD 6.1-RELEASE #1: Sat Jul 22 06:12:10 AST 2006
   [EMAIL PROTECTED]:/usr/src/sys/i386/compile/MYKERNEL
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Genuine Intel(R) CPU T2300 @ 1.66GHz (1662.51-MHz 686-class CPU)
 Origin = "GenuineIntel"  Id = 0x6e8  Stepping = 8
Features=0xbfe9fbff<FPU,VME,DE,PSE,TSC,MSR,PAE,MCE,CX8,APIC,SEP,MTRR,PGE,MCA,CMOV,PAT,CLFLUSH,DTS,ACPI,MMX,FXSR,SSE,SSE2,SS,HTT,TM,PBE>
 Features2=0xc1a9<SSE3,MON,VMX,EST,TM2,<b14>,<b15>>
 AMD Features=0x100000<NX>
 Cores per package: 2
real memory  = 1072168960 (1022 MB)
avail memory = 1040257024 (992 MB)
ACPI APIC Table: <HP     NISSAN  >
ioapic0: Changing APIC ID to 1
ioapic0 <Version 2.0> irqs 0-23 on motherboard
kbd1 at kbdmux0
ath_hal: 0.9.16.16 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
acpi0: <PTLTD Capell00> on motherboard
acpi_bus_number: can't get _ADR
acpi_bus_number: can't get _ADR
acpi_bus_number: can't get _ADR
acpi_bus_number: can't get _ADR
acpi_bus_number: can't get _ADR
acpi_bus_number: can't get _ADR
acpi_bus_number: can't get _ADR
acpi_bus_number: can't get _ADR
acpi0: Power Button (fixed)
acpi0: Sleep Button (fixed)
acpi_bus_number: can't get _ADR
acpi_bus_number: can't get _ADR
acpi_ec0: <Embedded Controller: GPE 0x19> port 0x62,0x66 on acpi0
Timecounter "ACPI-safe" frequency 3579545 Hz quality 1000
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x1008-0x100b on acpi0
cpu0: <ACPI CPU> on acpi0
acpi_throttle0: <ACPI CPU Throttling> on cpu0
acpi_lid0: <Control Method Lid Switch> on acpi0
acpi_button0: <Power Button> on acpi0
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
pcib1: <ACPI PCI-PCI bridge> irq 16 at device 1.0 on pci0
pci1: <ACPI PCI bus> on pcib1
pci1: <display, VGA> at device 0.0 (no driver attached)
pci0: <multimedia> at device 27.0 (no driver attached)
pcib2: <ACPI PCI-PCI bridge> irq 17 at device 28.0 on pci0
pci2: <ACPI PCI bus> on pcib2
pcib3: <ACPI PCI-PCI bridge> irq 16 at device 28.1 on pci0
pci3: <ACPI PCI bus> on pcib3
pcib4: <ACPI PCI-PCI bridge> irq 18 at device 28.2 on pci0
pci6: <ACPI PCI bus> on pcib4
pci6: <network> at device 0.0 (no driver attached)
uhci0: <UHCI (generic) USB controller> port 0x1800-0x181f irq 23 at device 29.0 on pci0
uhci0: [GIANT-LOCKED]
usb0: <UHCI (generic) USB controller> on uhci0
usb0: USB revision 1.0
uhub0: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
uhci1: <UHCI (generic) USB controller> port 0x1820-0x183f irq 19 at device 29.1 on pci0
uhci1: [GIANT-LOCKED]
usb1: <UHCI (generic) USB controller> on uhci1
usb1: USB revision 1.0
uhub1: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
uhci2: <UHCI (generic) USB controller> port 0x1840-0x185f irq 18 at device 29.2 on pci0
uhci2: [GIANT-LOCKED]
usb2: <UHCI (generic) USB controller> on uhci2
usb2: USB revision 1.0
uhub2: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub2: 2 ports with 2 removable, self powered
uhci3: <UHCI (generic) USB controller> port 0x1860-0x187f irq 16 at device 29.3 on pci0
uhci3: [GIANT-LOCKED]
usb3: <UHCI (generic) USB controller> on uhci3
usb3: USB revision 1.0
uhub3: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub3: 2 ports with 2 removable, self powered
ehci0: <Intel 82801GB/R (ICH7) USB 2.0 controller> mem 0xd2404000-0xd24043ff irq 23 at device 29.7 on pci0
ehci0: [GIANT-LOCKED]
usb4: waiting for BIOS to give up control
usb4: timed out waiting for BIOS
usb4: EHCI version 1.0
usb4: companion controllers, 2 ports each: usb0 usb1 usb2 usb3
usb4: <Intel 82801GB/R (ICH7) USB 2.0 controller> on ehci0
usb4: USB revision 2.0
uhub4: Intel EHCI root hub, class 9/0, rev 2.00/1.00, addr 1
uhub4: 8 ports with 8 removable, self powered
pcib5: <ACPI PCI-PCI bridge> at device 30.0 on pci0
pci8: <ACPI PCI bus> on pcib5
cbb0: <PCI-CardBus Bridge> mem 0xd2004000-0xd2004fff irq 18 at device 6.0 on pci8
cardbus0: <CardBus bus> on cbb0
pccard0: <16-bit PCCard bus> on cbb0
fwohci0: <1394 Open Host Controller Interface> mem 0xd2007000-0xd20077ff,0xd2000000-0xd2003fff irq 19 at device 6.1 on pci8
fwohci0: OHCI version 1.10 (ROM=0)
fwohci0: No. of Isochronous channels is 4.
fwohci0: EUI64 63:3f:02:00:1e:6c:41:84
fwohci0: Phy 1394a available S400, 3 ports.
fwohci0: Link S400, max_rec 2048 bytes.
firewire0: <IEEE1394(FireWire) bus> on fwohci0
fwe0: <Ethernet over FireWire> on firewire0
if_fwe0: Fake Ethernet address: 62:3f:02:6c:41:84
fwe0: Ethernet address: 62:3f:02:6c:41:84
fwe0: if_start running deferred for Giant
sbp0: <SBP-2/SCSI over FireWire> on firewire0
fwohci0: Initiate bus reset
fwohci0: node_id=0xc800ffc0, gen=1, CYCLEMASTER mode
firewire0: 1 nodes, maxhop <= 0, cable IRM = 0 (me)
firewire0: bus manager 0 (me)
pci8: <mass storage> at device 6.2 (no driver attached)
pci8: <base peripheral> at device 6.3 (no driver attached)
fxp0: <Intel Pro/100 VE Network Connection> port 0x2000-0x203f mem 0xd2006000-0xd2006fff irq 20 at device 8.0 on pci8
miibus0: <MII bus> on fxp0
inphy0: <i82562ET 10/100 media interface> on miibus0
inphy0:  10baseT, 10baseT-FDX, 100baseTX, 100baseTX-FDX, auto
fxp0: Ethernet address: 00:16:d4:01:61:7e
isab0: <PCI-ISA bridge> at device 31.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <Intel ICH7 UDMA100 controller> port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0x1880-0x188f at device 31.1 on pci0
ata0: <ATA channel 0> on atapci0
ata1: <ATA channel 1> on atapci0
atapci1: <Intel ICH7 SATA300 controller> port 0x18c8-0x18cf,0x18ac-0x18af,0x18c0-0x18c7,0x18a8-0x18ab,0x18b0-0x18bf mem 0xd2404400-0xd24047ff irq 19 at device 31.2 on pci0
ata2: <ATA channel 0> on atapci1
ata3: <ATA channel 1> on atapci1
ata4: <ATA channel 2> on atapci1
ata5: <ATA channel 3> on atapci1
pci0: <serial bus, SMBus> at device 31.3 (no driver attached)
acpi_tz0: <Thermal Zone> on acpi0
acpi_tz1: <Thermal Zone> on acpi0
battery0: <ACPI Control Method Battery> on acpi0
atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
psm0: <PS/2 Mouse> irq 12 on atkbdc0
psm0: [GIANT-LOCKED]
psm0: model IntelliMouse, device ID 3
acpi_acad0: <AC Adapter> on acpi0
pmtimer0 on isa0
orm0: <ISA Option ROMs> at iomem 0xc0000-0xcefff,0xcf000-0xd07ff,0xe0000-0xe17ff,0xe3800-0xe3fff on isa0
ppc0: parallel port not found.
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
sio0: configured irq 4 not in bitmap of probed irqs 0
sio0: port may not be enabled
sio0 at port 0x3f8-0x3ff irq 4 flags 0x10 on isa0
sio0: type 8250 or not responding
sio1: configured irq 3 not in bitmap of probed irqs 0
sio1: port may not be enabled
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
ugen0: Broadcom Corp HP Integrated Module, rev 2.00/1.00, addr 2
Timecounter "TSC" frequency 1662512680 Hz quality 800
Timecounters tick every 1.000 msec
acd0: DVDR <HL-DT-ST DVDRAM GSA-4084N/KQ09> at ata0-master PIO4
ad4: 95396MB <HTS541010G9SA00 MBZOC60P> at ata2-master SATA150
Trying to mount root from ufs:/dev/ad4s1a
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to