In the last episode (Jul 21), Harlan Stenn said:
> I recently installed FreeBSD 6.1-STABLE on a machine, along with xorg
> and gnome2.
> When the machine boots up and runs /etc/rc.d/ldconfig it generates a
> message about how it is ignoring /usr/X11R6/lib because it is
> group-writable.
> This means that xdm gives me a login screen but I cannot log in there
> as cannot be found (it's in /usr/X11R6/lib).
> While I can "fix" the group perms manually, as soon as I run
> portupgrade the mtree stuff puts the perms back to 775 on
> /usr/X11R6/lib.

/etc/mtree/BSD.x11.dist has everything marked 755, though, and a quick
grep of /var/db/pkg/*/+MTREE_DIRS on my system only has one
mode-775 directory ( /usr/X11R6/share/gnome/games ).

My guess is that at some point, a port or manual install on your system
chmod'ed X11R6/lib/, and every port installed after that recorded the
wrong permissions in their mtree file.  If "grep 775
/var/db/pkg/*/+MTREE_DIRS" lists a bunch of lines, you might be able to
sed them back to normal with something like

  sed -i .bak -e 's/mode=0775/mode=0755/' /var/db/pkg/*/_MTREE_DIRS

A hack until you get the permissions worked out would be to add
ldconfig_insecure="yes" to /etc/rc.conf, which will make
/etc/rc.d/ldconfig add the -i flag when it runs ldconfig.

        Dan Nelson
_______________________________________________ mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to