Filippo Moretti skrev:
Frank Staals wrote:
Filippo Moretti wrote:
Chuck Swiger wrote:
Filippo Moretti wrote:
I run 6.1_STABLE on i386 arch and when I tried to upgrade mplayer I get the following error
c++: Internal error: Killed: 9 (program cc1plus)

Mostly likely, you've got hardware problems like bad memory or an overheating CPU. Either run some system diagonstics like memtest86, or retry the compile after the machine has been off for an hour, and see whether it fails in the same place.

After following your suggestion I get another error which repeted three times even after switching off the computer for the whole night:
===>  Configuring for lirc-0.7.2
creating cache ./config.cache
checking for a BSD compatible install... /usr/bin/install -c -o root -g wheel
checking whether build environment is sane... yes
checking for mawk... no
checking for gawk... no
checking for nawk... nawk
checking whether gmake sets ${MAKE}... yes
checking for gcc... cc
checking whether the C compiler (cc -O2 -g -Wall ) works... yes
checking whether the C compiler (cc -O2 -g -Wall ) is a cross-compiler... no
checking whether we are using GNU C... yes
checking whether cc accepts -g... yes
checking for style of include used by gmake... GNU
ng dependency style of cc... gcc3
checking for a BSD compatible install... /usr/bin/install -c -o root -g wheel
checking whether gmake sets ${MAKE}... (cached) yes
checking for mknod... /sbin//mknod
checking for mkfifo... /usr/bin/mkfifo
checking for depmod... /sbin/depmod
checking for libusb-config... no
checking whether ln -s works... yes
checking for Cygwin environment... no
checking for mingw32 environment... no
checking how to run the C preprocessor... cc -E
checking host system type... i386-unknown-freebsd6.1
checking build system type... i386-portbld-freebsd6.1
checking for ld used by GCC... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for /usr/bin/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/bin/nm -B
checking for a sed that does not truncate output... /usr/bin/sed
checking how to recognise dependent libraries... pass_all
checking for object suffix... o
checking for executable suffix... no
checking command to parse /usr/bin/nm -B output... ok
checking for dlfcn.h... yes
checking for fcntl.h... yes
checking for limits.h... yes
checking for sys/ioctl.h... yes
checking for sys/time.h... yes
checking for syslog.h... yes
checking for unistd.h... yes
checking for working const... yes
checking for inline... inline
checking for off_t... yes
checking for pid_t... yes
checking for size_t... yes
checking whether struct tm is in sys/time.h or time.h... time.h
checking return type of signal handlers... void
checking for vprintf... yes
checking for gethostname... yes
checking for gettimeofday... yes
checking for mkfifo... yes
checking for select... yes
checking for socket... yes
checking for strdup... yes
checking for strerror... yes
checking for strtoul... yes
checking for snprintf... yes
checking for strsep... yes
checking for vsyslog... yes
checking for daemon... yes
checking for forkpty... no
checking for forkpty in -lutil... yes
checking for vga.h... no
checking for X... libraries /usr/X11R6/lib, headers /usr/X11R6/include
checking for dnet_ntoa in -ldnet... no
checking for dnet_ntoa in -ldnet_stub... no
checking for gethostbyname... yes
checking for connect... yes
checking for remove... yes
checking for shmat... yes
checking for IceConnectionNumber in -lICE... yes
checking for getopt_long... yes
checking for mktemp... yes
checking for Linux kernel sources... not running Linux
checking for which drivers can be installed on this system...
checking for caraca_init in -lcaraca_client... no
checking for ir_strerror in -lirman... no
checking for ir_strerror in -lirman_sw... no
checking for portaudio.h... no
checking for alsa/asoundlib.h... no
checking for scsi/sg.h... no
checking for linux/input.h... no
checking for sys/soundcard.h... yes
configure: error: *** it is not possible to install the specified driver
       on this system
===>  Script "configure" failed unexpectedly.
Please report the problem to [EMAIL PROTECTED] [maintainer] and attach the "/usr/ports/comms/lirc/work/lirc-0.7.2/config.log" including the output of the failure of your make command. Also, it might be a good idea to provide
an overview of all packages installed on your system (e.g. an `ls
*** Error code 1

Stop in /usr/ports/comms/lirc.
*** Error code 1

Stop in /usr/ports/multimedia/mplayer.
** Command failed [exit code 1]: /usr/bin/script -qa /tmp/portupgrade11994.17 env PORT_UPGRADE=yes make PORT_UPGRADE=yes
** Fix the problem and try again.
** Listing the failed packages (*:skipped / !:failed)
       ! multimedia/mplayer (mplayer-esound-0.99.7_15) (configure error)
--->  Packages processed: 0 done, 192 ignored, 0 skipped and 1 failed
Do you think this one to be an hardware failure as well
_______________________________________________ mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Probbly just something wrong with the lirc port, try to run a make clean in comms/lirc and rebuild it.
The error persists after make clean

Could there be a problem with your options file?
Do a 'make rmconfig' if you are not sure.

Or check that this has output first:
diff /var/db/ports/mplayer/options /var/db/ports/mplayer-skins/options

Because it looks similar to something that happened to me:
On my system something went wrong with mplayers options file.
It was overwritten with mplayer-skins options file.
But I did not identify how that happened.
Could also have been a config-script i tried out.

- Regards from Lars

By the way: I would reccomend manually compiling the CVS version of mplayer ( ah wel they are using subversion ATM but hence it's about the idea ) Then you have an up to date mplayer + ffmpeg. New official releases of mplayer are rare ....

_______________________________________________ mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

_______________________________________________ mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to