FreeBSD 6.1
saslauthd version 2.1.22
sendmail version 8.13.6

My problem is that sendmail is not authenticating plain text passwords.

From my /etc/mail/hostname.mc file:

define(`confAUTH_MECHANISMS',`PLAIN LOGIN')dnl
TRUST_AUTH_MECH(`PLAIN LOGIN')dnl

However when I telnet to the server I find the following:

250-AUTH GSSAPI DIGEST-MD5 CRAM-MD5

From my /etc/make.conf:

SENDMAIL_CFLAGS=-I/usr/local/include -DSASL=2
SENDMAIL_LDFLAGS=-L/usr/local/lib
SENDMAIL_LDADD=-lsasl2

From my /usr/local/lib/sasl2/Sendmail.conf file:

pwcheck_method: saslauthd

From my /var/log/maillog file:

Jul 30 23:08:01 mail sendmail[4061]: NOQUEUE: connect from [EMAIL PROTECTED]
Jul 30 23:08:01 mail sendmail[4061]: STARTTLS: ServerCertFile missing
Jul 30 23:08:01 mail sendmail[4061]: AUTH: available mech=NTLM LOGIN ANONYMOUS PLAIN GSSAPI OTP DIGEST-MD5 CRAM-MD5, allowed mech=EXTERNAL GSSAPI KERBEROS_V4 DIGEST-MD5 CRAM-MD5 Jul 30 23:08:01 mail sendmail[4061]: k6V481s5004061: Milter: no active filter

Everything seems to be in place. SASL is running, and is working fine with the included testing tools, but sendmail does not seem to be accepting plain text logins. This is the same setup I have up and running on a 6.0 box, but it doesn't seem to be working now. Any ideas on what I might have screwed up?

TIA
Greg Groth
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to