On Mon, 31 Jul 2006 23:07:39 +0800
"jan gestre" <[EMAIL PROTECTED]> wrote:

> hi guys,
> 
> portaudit reperoted a vulnerability on the ruby package, so i did the
> following:
> 
> # cvsup -L 2 ports-supfile
> # portsdb -Uu
> # portupgrade -rR ruby
> 
> but i encountered this error message, i can't upgrade ruby.
> 
> --->  Upgrading 'ruby-1.8.4_8,1' to 'ruby-1.8.4_9,1' (lang/ruby18)
> --->  Building '/usr/ports/lang/ruby18'
> ===>  Cleaning for ruby-1.8.4_9,1
> 
> NOTE:
> You can enable pthread support by defining WITH_PTHREADS variable,
> but not recommended since this might break some ruby apps.
> 
> ===>  ruby-1.8.4_9,1 has known vulnerabilities:
> => ruby - multiple vulnerabilities.
>    Reference: <
> http://www.FreeBSD.org/ports/portaudit/76562594-1f19-11db-b7d4-0008743bf21a.html
> >
> => ruby - multiple vulnerabilities.
>    Reference: <
> http://www.FreeBSD.org/ports/portaudit/76562594-1f19-11db-b7d4-0008743bf21a.html
> >
> => Please update your ports tree and try again.
> *** Error code 1
> 
> Stop in /usr/ports/lang/ruby18.
> ** Command failed [exit code 1]: /usr/bin/script -qa /tmp/portupgrade94211.0
> env PORT_UPGRADE=yes make PORT_UPGRADE=yes
> ** Fix the problem and try again.
> --->  Skipping 'databases/ruby-bdb' (ruby18-bdb-0.5.9_2) because a requisite
> package 'ruby-1.8.4_8,1' (lang/ruby18) failed (specify -k to force)
> --->  Skipping 'sysutils/portupgrade' (portupgrade-2.1.3.2_2,2) because a
> requisite package 'ruby-1.8.4_8,1' (lang/ruby18) failed (specify -k to
> force)
> ** Listing the failed packages (*:skipped / !:failed)
>         ! lang/ruby18 (ruby-1.8.4_8,1)  (unknown build error)
>         * databases/ruby-bdb (ruby18-bdb-0.5.9_2)
>         * sysutils/portupgrade (portupgrade-2.1.3.2_2,2)
> --->  Packages processed: 0 done, 0 ignored, 2 skipped and 1 failed
> 
> any ideas on how to fix this?
> 
> TIA
> 

It may be that portaudit is preventing you from updating.  You could
try:
        portupgrade -Rr -m DISABLE_VULNERABILITIES="yes" ruby

and see if that allows you to update. I use the 
-m DISABLE_VULNERABILITIES="yes" all the time for updating.

HTH,

Randy

-- 
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to