On Wed, Aug 02, 2006 at 02:22:18PM +0200, Bobby Knight wrote:
> Hello    Newly installed 6.1. 

I recently said hello to a newly installed FreeBSD 6.1 myself.

> Barely touched ports so one would expect it to work, 

That sounds like a reasonable expectation for FreeBSD.  I'm new to FreeBSD
myself.  For the most part I've found it quite stable.  I've been a Linux
user for years(since the 1.x kernel days) and after only a few days of
tinkering with FreeBSD on a test box I'm just about ready to switch my main
box over to FreeBSD.

> yet it fails brutally for me as  a new user when I do portupgrade -arR
> just to upgrade a few packages.    

I experienced a similar failure to the one you describe, although I didn't
find it all that brutal.  After a few tries I managed to get past it.

> I have no clue why and what to do so I am hoping someone here knows. 

I don't really have a clue as to why myself but I'll tell you what worked
for me.  There may be a better solution to this and if so hopefully someone
with more knowledge than I will point it out.  To improve your chances of
getting the answers you need you might want to consider paying attention to
the guidelines posted occasionally, especially the part about including line
breaks.  Such a post can be found at:

Reformatting your post so I could reply to it took a bit of time.  Since I
had a similar problem I took the time to reformat your message and reply to
it with the hope that it will encourage someone who might not otherwise have
repiled to provide more information and a better solution to the problem.

> Can't see what I have done wrong. 

My guess is you haven't done anything wrong.  I had the same problem.  

> That is always cvsup ports and do a portsdb -Fu; portaudit -Fa before
> upgrade as well as read UPDATING.    

I use portsnap myself and just installed portupgrade and portaudit
yesterday.  I'm still learning all the proper steps necessary to keep my
system up to date.

> Checking if devel/pkg-config already installed  ===>   pkg-config-0.20_2
> is already installed        
> You may wish to ``make deinstall'' and install this port again by ``make
> reinstall'' to upgrade it properly.

I tried a 'make deinstall' then 'make reinstall' as the error message
suggested.  It didn't help.  Then, I tried a 'make deinstall' followed by a
'portupgrade -aRr' which appeared to get around the problem.  Portupgrade
installed the version of pkg-config it really wanted and upgraded
everything successfully.

Bruceville, TX

Si hoc legere scis nimium eruditionis habes.
_______________________________________________ mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to