On Friday 04 August 2006 14:34, David Johnson wrote:
> Like millions of other users, my printing capabilities came to an abrupt
> end when I upgraded cups to version 1.2. After weeks of wasting time on
> the problem, I'm still not printing.
> I've seen lots of hints and tips on this list and elsewhere, but they
> just don't work for me. I also get the sense they're not working for
> lots of other people either. I have a brand new (three months) laserjet
> printer, and I'll be damned if I have to reboot into Windows to use it!
> I can "downgrade" to an older cups, but that's not a permanent solution.
> Symptoms:
> Nothing happens when I print a file (or print test page). I've waited up
> to ten minutes. When I cancel the job and start a new one, I then get
> the following message in the cups admin page: "USB port busy; will
> retry in 30 seconds...". This message stays even after unplugging
> printer USB port. A restart of cupsd is necessary to make it go away.
> OS:
> Printer:
> HP LaserJet 1320, USB
> Using ppd file downloaded from linuxprinting.org
> lpstat -t output (without the port busy message):
> scheduler is running
> system default destination: laserjet
> device for laserjet: usb:/dev/ulpt0
> laserjet accepting requests since Fri Aug  4 11:20:53 2006
> printer laserjet now printing laserjet-36.  enabled since Fri Aug  4
> 11:20:53 2006
> laserjet-36             root             18432   Fri Aug  4 11:20:53
> 2006
> Relevant packages:
> cups-1.2.0
> cups-base-1.2.0_2
> cups-pstoraster-8.15
> (not using hplip, should I?)
> dmesg:
> ulpt0: Hewlett-Packard hp LaserJet 1320 series, rev 1.10/1.00, addr 2,
> iclass 7/1
> ulpt0: using bi-directional mode
> Permissions on devices:
> crw-rw----  1 root  cups    0, 151 Aug  4 08:43 /dev/ulpt0
> crw-rw----  1 root  cups    0, 152 Aug  4 08:43 /dev/unlpt0
> All BSD printing executables have been renamed out of the way (lp.org,
> lpr.org, etc). The old cups.sh script no longer exists. devfs.rules was
> modified according to some tips found floating about online. I also
> note that these tips, which seems to be necessary, are not in the
> handbook or in any pkg_message file.
> Any help leading to a solution will be greatly appreciated. I would also
> love to see the cups ports provide sufficient (and correct)
> documentation to get printing to work.

You have the permissions fixed, which was half the solution for me when I made 
the upgrade. The other half was to abandon cups' usb back-end for the time 
being, since it doesn't work (as well as it used to). The workaround 
suggested in an earlier thread on this subject was to stop cups and manually 
edit the printers.conf file (in /usr/local/etc/cups), replacing the "usb:" 
portion of the printer URI with "file:". This worked for me and several 
others, although I remember posts that it did not work for some.


freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to