On 8/6/06, Mark Kane <[EMAIL PROTECTED]> wrote:
Hi everyone. Quick hardware question here...

We're looking to move a dedicated server to a new datacenter with new
hardware. The Dual Xeon boards in the new datacenter are the Supermicro
X6DVL-EG-2 with the Intel E7320 chipset. I see the E7320 listed on
the hardware page for 6.1-RELEASE/amd64 but not for i386. Would this
work with i386? I want to run i386 on this machine just to make sure all
third party software we need will still work, since it is an important
production server, and one application we use is binary only for i386.

I also don't see the SATA controller (6300ESB) or the onboard NIC
(82541GI) on either hardware lists. I see similar models for the NIC
on the list, but not the "GI". The motherboard spec page does show
different models though, since at the top it says it's the "GI", but
down below it says it's the "PI" on that board. Does neither the SATA or
NIC being listed mean that this board will not work? Is anyone out there
running this board with FreeBSD, and what are your experiences with it?

I don't know much about Intel hardware since I run AMD on all other
machines, and most any hardware I've ever used with FreeBSD has worked,
but I wanted to check on this before ordering the new server because
we're needing to switch fast and get moved out of the old datacenter
by mid-week. The only other hardware option I see from this datacenter
is an Opteron 170, but I'd like to stick with the Dual Xeons as we
currently have now if at all possible.

Thanks very much in advance for any info or suggestions.



I have a X7DBE that mostly works with FreeBSD 6.x/i386.


The Ethernet controllers (Intel PRO/1000 EB) don't work with FreeBSD
6.1 but this is being fixed on -STABLE as we speak, there is a em(4)
patch waiting for commit... I have not tried to use the 6 port onboard
SATA RAID controller... From experience I just assume it not support
at all. Your motherboard is a generation behind my board so things
should probably work out pretty good for you. here's my dmesg:

Copyright (c) 1992-2006 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
       The Regents of the University of California. All rights reserved.
FreeBSD 6.1-STABLE #0: Mon Aug  7 00:13:42 UTC 2006
   [EMAIL PROTECTED]:/usr/obj/usr/src/sys/X7DBE
ACPI APIC Table: <PTLTD          APIC  >
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Intel(R) Xeon(TM) CPU 2.66GHz (2666.68-MHz 686-class CPU)
 Origin = "GenuineIntel"  Id = 0xf64  Stepping = 4
 AMD Features=0x20000000<LM>
 AMD Features2=0x1<LAHF>
 Cores per package: 2
 Logical CPUs per core: 2
real memory  = 1073086464 (1023 MB)
avail memory = 1036750848 (988 MB)
FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
cpu0 (BSP): APIC ID:  0
cpu1 (AP): APIC ID:  2
ioapic0 <Version 2.0> irqs 0-23 on motherboard
ioapic1 <Version 2.0> irqs 24-47 on motherboard
kbd1 at kbdmux0
acpi0: <PTLTD   RSDT> on motherboard
acpi0: Power Button (fixed)
can't fetch resources for \\_SB_.PCI0.LPC0.MBRD - AE_AML_INVALID_RESOURCE_TYPE
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x1008-0x100b on acpi0
cpu0: <ACPI CPU> on acpi0
acpi_throttle0: <ACPI CPU Throttling> on cpu0
cpu1: <ACPI CPU> on acpi0
acpi_throttle1: <ACPI CPU Throttling> on cpu1
acpi_throttle1: failed to attach P_CNT
device_attach: acpi_throttle1 attach returned 6
pcib0: <ACPI Host-PCI bridge> port 0xcf8-0xcff on acpi0
pci0: <ACPI PCI bus> on pcib0
pcib1: <ACPI PCI-PCI bridge> at device 2.0 on pci0
pci1: <ACPI PCI bus> on pcib1
pcib2: <ACPI PCI-PCI bridge> irq 16 at device 0.0 on pci1
pci2: <ACPI PCI bus> on pcib2
pcib3: <ACPI PCI-PCI bridge> irq 16 at device 0.0 on pci2
pci3: <ACPI PCI bus> on pcib3
pcib4: <ACPI PCI-PCI bridge> at device 0.0 on pci3
pci4: <ACPI PCI bus> on pcib4
pcib5: <ACPI PCI-PCI bridge> at device 0.2 on pci3
pci5: <ACPI PCI bus> on pcib5
pcib6: <ACPI PCI-PCI bridge> irq 18 at device 2.0 on pci2
pci6: <ACPI PCI bus> on pcib6
em0: <Intel(R) PRO/1000 Network Connection Version - 6.0.5> port
0x2000-0x201f mem 0xc8200000-0xc821ffff irq 18 at device 0.0 on pci6
em0: Ethernet address: 00:30:48:30:99:c8
em0: [FAST]
em1: <Intel(R) PRO/1000 Network Connection Version - 6.0.5> port
0x2020-0x203f mem 0xc8220000-0xc823ffff irq 19 at device 0.1 on pci6
em1: Ethernet address: 00:30:48:30:99:c9
em1: [FAST]
pcib7: <ACPI PCI-PCI bridge> at device 0.3 on pci1
pci7: <ACPI PCI bus> on pcib7
pcib8: <ACPI PCI-PCI bridge> at device 4.0 on pci0
pci8: <ACPI PCI bus> on pcib8
pcib9: <ACPI PCI-PCI bridge> at device 6.0 on pci0
pci9: <ACPI PCI bus> on pcib9
pcib10: <PCI-PCI bridge> at device 0.0 on pci9
pci10: <PCI bus> on pcib10
arcmsr0: <Areca ARC-1220 PCI-Express 8 Port SATA RAID Controller
Driver Version> mem
0xc8300000-0xc8300fff,0xc8800000-0xc8bfffff irq 16 at device 14.0 on
arcmsr0: [GIANT-LOCKED]
pcib11: <PCI-PCI bridge> at device 0.2 on pci9
pci11: <PCI bus> on pcib11
pci0: <base peripheral> at device 8.0 (no driver attached)
pcib12: <ACPI PCI-PCI bridge> irq 17 at device 28.0 on pci0
pci12: <ACPI PCI bus> on pcib12
pci12: <network, ethernet> at device 0.0 (no driver attached)
uhci0: <UHCI (generic) USB controller> port 0x1800-0x181f irq 17 at
device 29.0 on pci0
usb0: <UHCI (generic) USB controller> on uhci0
usb0: USB revision 1.0
uhub0: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
uhci1: <UHCI (generic) USB controller> port 0x1820-0x183f irq 19 at
device 29.1 on pci0
usb1: <UHCI (generic) USB controller> on uhci1
usb1: USB revision 1.0
uhub1: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
uhci2: <UHCI (generic) USB controller> port 0x1840-0x185f irq 18 at
device 29.2 on pci0
usb2: <UHCI (generic) USB controller> on uhci2
usb2: USB revision 1.0
uhub2: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub2: 2 ports with 2 removable, self powered
ehci0: <EHCI (generic) USB 2.0 controller> mem 0xc8000000-0xc80003ff
irq 17 at device 29.7 on pci0
usb3: EHCI version 1.0
usb3: companion controllers, 2 ports each: usb0 usb1 usb2
usb3: <EHCI (generic) USB 2.0 controller> on ehci0
usb3: USB revision 2.0
uhub3: Intel EHCI root hub, class 9/0, rev 2.00/1.00, addr 1
uhub3: 6 ports with 6 removable, self powered
pcib13: <ACPI PCI-PCI bridge> at device 30.0 on pci0
pci13: <ACPI PCI bus> on pcib13
pci13: <display, VGA> at device 1.0 (no driver attached)
isab0: <PCI-ISA bridge> at device 31.0 on pci0
isa0: <ISA bus> on isab0
atapci0: <GENERIC ATA controller> port
0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0x1860-0x186f at device 31.1 on
ata0: <ATA channel 0> on atapci0
ata1: <ATA channel 1> on atapci0
ichsmb0: <SMBus controller> port 0x1100-0x111f irq 19 at device 31.3 on pci0
ichsmb0: [GIANT-LOCKED]
smbus0: <System Management Bus> on ichsmb0
smb0: <SMBus generic I/O> on smbus0
acpi_button0: <Power Button> on acpi0
atkbdc0: <Keyboard controller (i8042)> port 0x60,0x64 irq 1 on acpi0
atkbd0: <AT Keyboard> irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
sio0: <16550A-compatible COM port> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
sio0: type 16550A
sio1: <16550A-compatible COM port> port 0x2f8-0x2ff irq 3 on acpi0
sio1: type 16550A
fdc0: <floppy drive controller> port 0x3f0-0x3f5,0x3f7 irq 6 drq 2 on acpi0
fdc0: [FAST]
ppc0: <ECP parallel printer port> port 0x378-0x37f,0x778-0x77f irq 7
drq 3 on acpi0
ppc0: SMC-like chipset (ECP/EPP/PS2/NIBBLE) in COMPATIBLE mode
ppc0: FIFO with 16/16/9 bytes threshold
ppbus0: <Parallel port bus> on ppc0
plip0: <PLIP network interface> on ppbus0
lpt0: <Printer> on ppbus0
lpt0: Interrupt-driven port
ppi0: <Parallel I/O> on ppbus0
pmtimer0 on isa0
orm0: <ISA Option ROMs> at iomem 0xc0000-0xcafff,0xcb000-0xcbfff on isa0
sc0: <System console> at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
vga0: <Generic ISA VGA> at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
Timecounters tick every 1.000 msec
ad0: 6149MB <WDC AC36400L 08.09L08> at ata0-master UDMA33
Waiting 5 seconds for SCSI devices to settle
da0 at arcmsr0 bus 0 target 0 lun 0
da0: <Areca ARC-1220-VOL#00 R001> Fixed Direct Access SCSI-3 device
da0: 166.666MB/s transfers (83.333MHz, offset 32, 16bit), Tagged
Queueing Enabled
da0: 2002715MB (4101561856 512 byte sectors: 255H 63S/T 255310C)
SMP: AP CPU #1 Launched!
Trying to mount root from ufs:/dev/ad0s1a

BSD Podcasts @:
freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to