Frank Staals wrote:
I tried to setup my own mail and smtp-server with help from this webpage: . I sucessfully installed imap-uw and I got it up successfully. Allthough the stmp-part doesn't work for 100% yet: I can send mail as root :
Thanks in advance
Jonathan Horne wrote:
greetings frank, this reply is out of the list.

you need to at a minimum take a look at the file /etc/mail/access, or, as an even better alternative, consider installing/configuring sasl2-saslauthd and have people who send thru authenticate via plain.

if you would like to see an article i wrote on this, if you follow it line by line, you should have no problems getting it to work.

if i can be of any assistance with my article, feel free to drop me a line. i can be reached via this email address, or on aim/yahoo as LoudRedZ71.

cheers and good luck,

On Friday 04 August 2006 17:08, you wrote:
I tried to setup my own mail and smtp-server with help from this

I've gotten a bit further this weekend but I'm not 'there' yet. I could sucessfully send a e-mail by using 'mail' as normal user at my server. Allthough when I tried to send an e-mail from my laptop with my server as smtp server it kept prompting for my password and this is what was displayed in /var/log/maillog :

Aug 5 11:40:36 FStaals sm-mta[101]: k759eEva000101: Riza.FStaals.LAN [] did not issue MAIL/EXPN/VRFY/ETRN during connection to IPv4

When I googled if I could find a solution I came to this page : The solution oppered there was to add ' mech_list: login plain' to /usr/local/lib/sasl2/Sendmail.conf . So I did and it kind of worked, allthough now I can only send e-mail to other users at my server ( for example root ), when I try to mail to an external adress my log 'says' my message is rejected:

Aug 5 13:10:30 FStaals sm-mta[1495]: k75BATko001495: ruleset=check_rcpt, arg1=< [EMAIL PROTECTED]>, relay=Riza.FStaals.LAN [], reject=550 5.7.1 <fr
[EMAIL PROTECTED]>... Relaying denied
Aug 5 13:10:34 FStaals sm-mta[1495]: k75BATko001495: lost input channel from Ri
za.FStaals.LAN [] to IPv4 after rcpt
Aug 5 13:10:34 FStaals sm-mta[1495]: k75BATko001495: from=<[EMAIL PROTECTED]>, size=373, class=0, nrcpts=0, proto=ESMTP, daemon=IPv4, relay=Riza.FStaals.LAN [1]

I'm not sure what I have to do to get working correctly and I was hoping someone could give me some hints what I'm doing wrong. Also I'm not sure if it's a good idea to add the 'mech_list: login plain' to sasl2's Sendmail.conf ? Last but not least : I want sendmail to use SSL and listen to port 465. sockstat shows It isn't listening to that port, but I think it should, does anyone happen to know what it is I'm doing wrong at that point:

[EMAIL PROTECTED] sockstat -4 | grep sendmail
root     sendmail   1410  3  tcp4   *:25                  *:*
root     sendmail   1410  5  tcp4   *:587                 *:*

[EMAIL PROTECTED] cat /etc/mail/ | grep smtps
O DaemonPortOptions=Port=smtps, Name=TLSMTA, M=s

Many thanks,

-Frank Staals

-Frank Staals

_______________________________________________ mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to