>  On  Aug  7,  2006,  at  1:26  PM,  micman  wrote:

>  Hello.
>
>  PROBLEM
>  I  tried  and  configured  FreeBSD  6.1  for  many  days  and  I  mounted  
> my    
>  FAT  extended  partition  to  exchange  my  files  between  Windows  and  my 
>    
>  new  Operating  System.  That  was  OK.  After  I  tried  to  mount    
>  automatically  at  boot  this  partition  and  I  make  an  error    
>  (grammatical  error):  I  wrote  “acd0s5”  instead  of  “ad0s5”  in  /etc/  
>  fstab.
>  Now,  when  I  start  the  system,  I  receive  this  message  at  the  end  
> of    
>  the  boot  process:
>  "Can't  open  (No  such  file  or  directory)
>  /dev/acd0s5:  UNEXPECTED  INCONSISTENCY;  RUN  fsck_msdosfs  MANUALLY.
>  THE  FOLLOWING  FILE  SYSTEM  HAD  AN  UNEXPECTED  INCONSISTENCY:
>  msdosfs:  /dev/acd0s5  (/mnt/win)
>  Automatic  file  system  check  failed;  help!
>  Aug  7  20:08:07  int:  /bin/sh  on  /etc/rc  terminated  abnormally,  going 
>    
>  to  single  user  mode
>  Enter  full  pathname  of  shell  or  RETURN  for  /bin/sh:"
>
>  QUESTIONS
>  Can  I  rewrite  the  file  /etc/fstab  in  text  mode?
>  If  it's  possible,  how  can  I  do  this?
>
>  I  tried  fsck_manually  and  also  to  boot  by  option  '6'  ("Escape  to  
>   
>  loader")  but  I  was  not  able  to  resolve  the  problem.
>  If  someone  can  help  me,  thank  you.
__________________________
>  get into a console maybe by booting single user.
>  remote root as read/write you may or may not have to
>  remount root as write but...

>  mount -u /
>  ee /etc/fstab

>  fix the error hit [esc] cc [esc] a and you should be
>  good to go. 

>  hope that helps

>  -brian

I have tried. Result:

"can't exec mount -u / for single user: No such file or directory"
and
ee: not found

About "ee" in the "FreeBSD command reference" I have tried this:
"This is a simpler alternative to 'vi' and is installed as part of the FreeBSD 
base system. However it may not always be available (there
is /rescue/vi for emergencies when /usr is not mounted, but no emergency 'ee')."

I have tried 'vi': not found

But in my /rescue 'vi' is listed and I have this message:
"no terminal database found"
__________________________

>  You  can  go  to  single  user  mode  (4)  from  the  boot  menu  and  then  
> mount  -  
>  o  rw  /  .  Then  you  can  edit  /etc/fstab.

>  Pramod  Venugopal

I have tried. Result:

"can't exec mount -o rw / for single user: No such file or directory"
___________________________

Thank you for your answers. 
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to