On 8/13/06, Snuk the Great <[EMAIL PROTECTED]> wrote:
This has me puzzeled. Tonight I could not find out why my freeBSD machine
could not mount a windows share. Whenever I tried it the shell would just
freeze. After a few hours I tried disabling my wireless Access Point on the
windows machine and now I was able to mount the mount the share. After this
I tried a bunch of things to make mount work even when the Acces Point was
on, like changing the IP adress of the AP, but no luck.
First I figured it might be a port issue, so I tried forcing Samba to go
through a different port, but again no luck.

My guess is that your shell isn't freezing, it's just in a very long
wait state. MS Windows, and samba, tend to do this when they are
waiting for name resolution.

Let me explain my setup a bit:
My pc and the freeBSD machine are in a LAN.
This LAN has acces to the internet.
My pc has a WLAN card which server as a Wireless Access Point.
I use my pc to share the LAN with my Access Point, so this as well has acces
to the internet.
I am out of ideas what to trie/do. So I was hoping you guys can give me a
nudge in the right direction.

Check your name resolution first. Samba and windows both have tools to
troubleshoot NetBIOS name resolution. Do you have a WINS server? If
you haven't configured a WINS server samba/windows will use a
broadcast to ask "the network" what names are available, this can be
problematic on almost any network.

Try appending a `&` to the end of the mount command, or press CTL+z
after you start it to send it to the background. You should get your
shell back so you can watch the samba log files.

Perfection is just a word I use occasionally with mustard.
--Atom Powers--
freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to