Darek M wrote:

I am unable to use the 'postmap' program under 6.0- or 6.1-RELEASE. Instead of building a valid hash map, it puts in various data from what appears to be my /etc/master.passwd file, complete with crypted password. I believe that this is some type of a library issue.


I'm doing this with postfix-2.3.2 downloaded right off the website, but the same happened with earlier releases, as well as an install from the ports.

As an example, I use the file 'transport' which contains
# cat /etc/postfix/transport
*       smtp:[192.168.0.1]:25

The syntax is correct as I use it on 5.4 and 5.5 boxes (I've had to downgrade to that to be able to use postfix).

# uname -a
FreeBSD some.host.name 6.1-RELEASE FreeBSD 6.1-RELEASE #0: Fri Jul 14 13:43:37 EDT 2006 darek@:/usr/src/sys/i386/compile/SOME_KERNEL i386

# /usr/sbin/postmap transport

On a system where postmap works fine, this is what I get:

# strings /etc/postfix/transport
* smtp:[192.168.22.29]:25

Please scroll down to APPENDIX_1 to see the 'strings' output on a 6.1 box. I tried this on 6.0 and 6.1 installed on a number of different machines, all with the same result, so I don't think that this is a memory or hardware issue. I also tried this on 6.x, 4.10, 4.11, 5.4 and 5.5 on the same system, and only the 6.x installs failed in this way.

Also, scroll down to APPENDIX_2 for an strace of the postmap execution. You will note that the open, read, and write calls often have weird info in them (I believe the filename part), with parts of strings, and random characters, like 'open("ÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿ'


I got a couple USB-only Dell towers for my SMTP boxes, and FreeBSD below 6 doesn't recognize the keyboard during install. So I'm forced to use 6.x with these. Unless someone knows how to use a USB keyboard in 5.5 installs...

I have no 6.X boxes so can't help directly, though I find it hard to believe that postfix+6.X fails for everyone so strongly suspect something local to the way you have installed, though have no clue what.

Some help debugging, though: you sent the output of strace on 6.1 with the wacky file opens. Try the same strace on 5.X and then diff the two to see what ought to have been happening - that may give some clue as to what is actually going wrong.

As for USB keyboards + 5.5 - on 5.4 there was an install boot option "boot with USB keyboard" or somesuch. Don't know if that's still there with 5.5, but it sounds like you have a 5.4 CD so you could try that. The problem *may* be that 5.X doesn't support your USB chipset, of course - no idea how likely that is. Also search the BIOS for any USB related options and try fiddling with them! You don't mention the model of Dell, but you could try a google for the model + freebsd.

Searching the mailing list archives (or just plain google) for USB keyboard should turn up some stuff as well - possibly far too much!

Final thought - what about postfix-21? Does it do everything you need? Does it have the same problem?

hth,

--Alex



_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to