Tuomas wrote:
> ajm,
> 
> Thanks for taking the pains to reply.
> 
> This is what I tried:
> 
> localhost# newfs -L FreeBSD /dev/fd0
> newfs: wtfs: 512 bytes at sector 2879: Input/output error
> localhost# newfs_msdos -f 1440 -L MSDOS /dev/fd0
> /dev/fd0: 2847 sectors in 2847 FAT12 clusters (512 bytes/cluster)
> bps=512 spc=1 res=1 nft=2 rde=224 sec=2880 mid=0xf0 spf=9 spt=18 hds=2 hid=0
> newfs_msdos: /dev/fd0: Input/output error
> 
> On another forum, someone suggested to me that I should try FreeBSD 6.x.
> FreeBSD 5.x has, according to this guy, some problems with some floppies.
> 
> So maybe I try FreeBSD 6.x, or I will use Linux on this machine.


Hi,

I suspect the problem does not lie in FreeBSD, but elsewhere. Have you
tried using different floppy discs? Specially another brand? Maybe the
cable connecting your floppy drive is playing on you or even the drive
itself is faulty.

I just tried the following on a fresh 5.5-RELEASE install without any
problems:

# mount -t msdos /dev/fd0 /mnt
[...]
# fdformat /dev/fd0
# newfs -L FreeBSD /dev/fd0
# newfs_msdos -f 1440 -L MSDOS /dev/fd0


I hope this helps.

Cheers,
Mikhail.

-- 
Mikhail Goriachev
Webanoide

Telephone: +61 (0)3 62252501
Mobile Phone: +61 (0)4 38255158
E-Mail: [EMAIL PROTECTED]
Web: http://www.webanoide.org

PGP Key ID: 0x4E148A3B
PGP Key Fingerprint: D96B 7C14 79A5 8824 B99D 9562 F50E 2F5D 4E14 8A3B
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to