On Aug 30, 2006, at 1:28 PM, Xiao-Yong Jin wrote:

Hi, I wanna upgrade ghostscript to ghostscript-gpl-8.15 from
ghostscript-gnu-7.07.  I've installed the gpl version via port.  But
when I tried to pkg_delete the gnu version, it said

pkg_delete: package 'ghostscript-gnu-7.07_15' is required by these other packages
and may not be deinstalled:
ImageMagick-6.2.8.5
auctex-11.83
cm-super-0.3.3
dvipdfmx-20050831_2
dvipsk-tetex-5.95a_1
freetype-tools-1.3.1_3
ghostscript-gnu-commfont-7.07_3
gv-3.6.1
hplip-0.9.11
html2ps-letter-1.0.b4_1,1
teTeX-3.0_1
teTeX-base-3.0_9
transfig-3.2.4_1
xdvik-tetex-22.84.10
zh-CJK-4.6.0_1
zh-moefonts-cid-1.0_3

I'll probably also delete ghostscript-gnu-commfont-7.07_3 and
zh-moefonts-cid-1.0_3.  But is there anything more I should consider
harmful to my system when I switch ghostscript gnu to gpl?  Or simply
pkg_delete by --force is enough?

Thank you,
Xiao-Yong

Try pkg_delete -f {name of all ghostscript files here}. Then install the newest port version and be sure to run pkgdb -F afterwards so you can fix the package database, such that it references the right ghostscript.
-Garrett
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to