Googling the archives wasn't much help, so....

I have a test machine that boots a number of things, FreeBSD -stable
and -current among them. I tried installing the latest 5.0 CDs, and
that failed miserably (the install process insist you have a swap, but
can't find the one I use on ad0s6c). So I rebooted the system to go
back to -stable.

It failed to come up. Since this box runs a variety of OS's, including
two different FreeBSDs, I use grub to boot it. It loaded the grub
stage2 boot and then went to the grub command prompt. Trying to run
the boot by hand - via "root (hd0,1,a)" - gets the message "no such
partition". When I ask grub for a list of partitions, it lists the two
FreeBSD partitions, but says it can't find "sub-partitions" for them.

I can boot FreeBSD-stable - I haven't tried -current - as if it were
Windows: make the FreeBSD partition the active partition and run the
standard MBR.

I tried installing boot0. It lists the XP partition and the two
FreeBSD partitions (so much for Linux). Asking it to boot the two
FreeBSD partitions results in beeps. It boots XP just fine - which
means that entry is slightly more useful than the FreeBSD entries.

I tried getting the latest version of grub, but that's a no go. I can
boot it off the floppy, but it doesn't see sub-partitions either.

If I boot -stable from grub as described above, everything comes up
and works fine. I can even mount the -current partion and see that
everything is as it should be. But neither boot loader seems to work.

Clues? Hints? Request for more information? Help?

Mike Meyer <[EMAIL PROTECTED]>    
Independent WWW/Perforce/FreeBSD/Unix consultant, email for more information.

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-questions" in the body of the message

Reply via email to