On Wednesday 06 September 2006 19:05, Jonathan Horne wrote:
> On Wednesday 06 September 2006 13:16, [EMAIL PROTECTED] wrote:
> > On 9/6/06, Jonathan Horne <[EMAIL PROTECTED]> wrote:
> > > is it possible to have STABLE and RELENG built on a single build
> > > server? or further, is it possible to have 5.5 and 6.1 worlds built
> > > from the same machine?
> >
> > buildworld and buildkernel targets are
> > fairly sophisticated.
> >
> > The /usr/obj tree corresponds to the source
> > directory, so if you have your 5.5 sources in
> > /src/5.5
> > and your 6.1 sources in
> > /src/6.1 (or /usr/src/6.1 for that matter)
> >
> > the world(s) would be built in
> > /usr/obj/src/5.5/ and /usr/obj/src/6.1/
> > repsectively. (Or /usr/obj/usr/src/6.1)
> >
> > If the purpose is to buildworld on one
> > fast machine and then export it to slower
> > machines on th' network, this works
> > admirably well.
>
> thank you!!  this was the exact hint i was hoping for!
>
> cheers,
> jonathan

well, so far, kinda so good.

i was able to cvsup 5.5-RELENG, 6.1-STABLE, and 6.1-RELENG to my build box.  i 
did a test kernel on the 6.1-RELENG, and that went fine, pretty much as 
expected.  but the 5.5 will not build.  i get this error:

[EMAIL PROTECTED] /usr/5.5-RELENG/src]# make buildkernel KERNCONF=TYCHE

--------------------------------------------------------------
>>> Kernel build for TYCHE started on Thu Sep  7 06:48:26 CDT 2006
--------------------------------------------------------------
===> TYCHE
mkdir -p /usr/obj/usr/5.5-RELENG/src/sys

--------------------------------------------------------------
>>> stage 1: configuring the kernel
--------------------------------------------------------------
cd /usr/5.5-RELENG/src/sys/i386/conf;  
PATH=/usr/obj/usr/5.5-RELENG/src/i386/legacy/usr/sbin:/usr/obj/usr/5.5-RELENG/src/i386/legacy/usr/bin:/usr/obj/usr/5.5-RELENG/src/i386/legacy/usr/games:/usr/obj/usr/5.5-RELENG/src/i386/usr/sbin:/usr/obj/usr/5.5-RELENG/src/i386/usr/bin:/usr/obj/usr/5.5-RELENG/src/i386/usr/games:/sbin:/bin:/usr/sbin:/usr/bin
  
config  -d /usr/obj/usr/5.5-RELENG/src/sys/TYCHE  
/usr/5.5-RELENG/src/sys/i386/conf/TYCHE
../../conf/files: coda/coda_fbsd.c must be optional, mandatory or standard
*** Error code 1

Stop in /usr/5.5-RELENG/src.
*** Error code 1

Stop in /usr/5.5-RELENG/src.

should building parts of 5.5 from a 6.1-buildserver be possible?  or should i 
install 5.5 on my buildserver, and compile 5.5 from there as well as the 
higher versions?

thanks,
jonathan
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to