I am an absolute FreeBSD Newbie and I decided to give it a try over a
lazy weekend - mainly because I don't want to throw away my old PIII
box. I picked up FreeBSD 5.4 which was all I got and I am dual booting
it with RHEL4.3. My box is rather old ... P3 733 Mhz with 256 megs of
[EMAIL PROTECTED], and I installed FreeBSD on the first 6.5 Gigs of my
Seagate harddrive ... connected to the Primary master IDE interface.

Now I had these two FreeBSD 5.4 ISOs ... CD1 and CD2, and I booted
from CD1 directly and did the install. There is no automatic X
configuration in the installer so I tried running it manually.

1. I tried running "Xorg -configure". For some reason "Xorg
-configure" threw an error:
xf86EnableIO: could not open /dev/io for extended IO. However, when I did run:

ls -l /dev/io

I got:

crw------- root wheel 246, 14 /dev/io

2. Never figured out what went wrong there but instead used
"xorgconfig" and that "worked", as in, it wrote my config file. Here
are my Screen details:

*** Samsung Samtron 45Bn monitor (33-55 KHz HorSyncRate, 50-120 Hz
Vert Refresh Rate).
*** Cirrus Logic GD 5465 graphics card on a PCI slot - with 4MB video memory.
*** For one, I have an immovable mouse ... it is an old haggardly
Logitech 3-button serial mouse and I could not make it work. Don't
know which is the device name to use for the port it is connected to.
Should it be /dev/tty00 or /dev/cuad0 or /dev/sysmouse or /dev/mse0?
So could not configure it.
- Tried running sysinstall to configure it but that would not work
either ... tried Logitech, Microsoft and MouseMan protocols and
/dev/tty00 and /dev/cuad0 for device names ... all combinations. Did
not work.

I would have liked to attach my xorg.conf file but don't have access
to it right away. I guess there are no probs in it ... I read through
the relevant sections of it and from what I remember of my RedHat
Linux 6.0 days, this file seems fine.

3. Finally I tried changing the /etc/ttys file and for /dev/ttyv8,
turned xterm "on" from "off".

==>> Now each time I boot into FreeBSD, I get a flickering blank,
black screen with nothing on it. I keep try [Ctrl+] Alt + F<n>
...n=1..12 ... but no success.
==>> I keep trying Ctrl + Alt + Backspace ... but no breakthrough.
==>> I tried Ctrl + Alt + KP_+/- also, with the Num Lock on ... but
again no respite.

Some observations:
1. While the screen continuously flickers, the Num Lock of the
Keyboard keeps blinking too (if it was on, to start with).
2. A while back, when I had not yet configured X with xorgconfig and
just like that switched on "xterm" on /dev/ttyv8, I rememeber the
getty program was respawning too quickly, due to which it was going
into 30 second sleeps. So I switched xterm off. Of course, after that
I found xorgconfig.

3. Here are the modes I have allowed in xorgconfig:
a. 8 bit - 800x600, 640x480 (removed 1024x768, 1280x1024)
b. 16 bit (default) - 800x600, 640x480 (removed 1024x768, 1280x1024)
c. 24 bit - 800x600, 640x480 (removed 1024x768, 1280x1024)

4. Earlier, after completing xorgconfig, while xterm was off on ttyv8
in /etc/ttys, I tried:
startx -- -depth 16 :1 vt10
and it gave me the same problems.

5. Finally, during sysinstall installation of the OS, I could not
configure moused with my mouse ... and while I would briefly see a
tiny pointer, I would not see it move with my mouse movements.

If you can wade through this gibberish, please help.

freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to