Arindam writes:

I am an absolute FreeBSD Newbie and I decided to give it a try over a
lazy weekend - mainly because I don't want to throw away my old PIII
box. I picked up FreeBSD 5.4 which was all I got and I am dual booting
it with RHEL4.3. My box is rather old ... P3 733 Mhz with 256 megs of
[EMAIL PROTECTED], and I installed FreeBSD on the first 6.5 Gigs of my
Seagate harddrive ... connected to the Primary master IDE interface.

Well, installing FreeBSD for the first time is more compatible with
an ambitious weekend than an lazy one - as you probably have discovered.
It does take considerable work, though the rewards are commensurate.
If you can wade through this gibberish, please help.

Some updates:
Following this I did a fresh install using the FreeBSD6.1 CD1. Xorg
installed is 6.9.0.
I did not run xorgconfig or anything. There was no /etc/X11/xorg.conf
either. From the command-line I ran "xdm" and the GUI started ... I
could login ... and then that's about it. 1. The Mouse still does not work ... may be I should try MouseSystems protocol.

I can't say much about the mouse.   I usually let it figure out
things itself and it works.  Is it a plain ps2 mouse (with round ps2
connector)? I just do the mouse test during sysinstall and it works.
2. What should I do about GNOME / KDE etc. I am not aching to get a
jazzy a GUI on my FreeBSD installation. I can make do with a very
minimal one. But I want a minimal one at least now, I just have to get
this running or I can't sleep.

If you don't want a fancy GUI desktop, then skip KDE and Gnome.
I prefer to use Afterstep.   It installs nicely.
It is found in ports at    /usr/ports/x11-wm/afterstep
It can be a little confusing at first to set up and configure - as are
all X things - but after getting it configured for me, it gives me what I
need: several windows for logging in to various hosts, a button to bring
up Firefoxand X support for whatever I run, such as OpenOffice or Xpdf
or Xmahjongg and a couple of other games, etc.
The only thing I haven't managed to my liking is getting it to create
anchor buttons for each thing when I bring it up.  It only does so for the
minimized windows.   I got that in one version, but it seemed to mess up
the focus control and click to bring forward action so I gave up on that.
I edited:   /usr/X11R6/lib/X11/xinit/xinitrc
to make it work my way.   I think you can make individual .xinitrc files
in home directories as well, but I wanted mine to work for all of my
small handful of accounts so I edited the main one. Have fun, ////jerry
_______________________________________________ mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

_______________________________________________ mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to