At Thu, 14 Sep 2006 12:40:13 +0200,
Jonathan McKeown wrote:
> On Wednesday 13 September 2006 14:59, Jonathan McKeown wrote:
> > I'm using my laptop and tip(1) as a serial terminal. This is working well
> > when a machine is booted with the laptop connected to its serial port.
> > However, I need to be able to connect the laptop to a machine which was
> > booted without a serial console.
> >
> > I've set the ttyd0 line in /etc/ttys and sigHUPed init. The machine is
> > still not recognising the presence of the ``serial terminal'' - the
> > getty(1) process on the server is not bound to a controlling terminal and
> > nothing is appearing in the tip(1) screen on the laptop.
> OK, creating a line in /etc/ttys for cuad0 seems to have worked. Will that 
> cause problems later? I assume the problem is that the tip(1) process (or 
> possibly the USB-serial adapter) is not DTRT with respect to carrier. Is 
> there any other way round this?
> Jonathan

Perhaps your serial cable is not a null-modem cable, but an interlink
cable.  These are similar, but has different pin assignments.
The former generates a carrier signal but the latter is not.

See the FreeBSD Handbook:

By the way, if a serial port is set to the console, the port is set to
CLOCAL mode (see stty(1)).  In this mode, getty(8) can output the
login prompt to the port without a carrier signal.
Watanabe Kazuhiro ([EMAIL PROTECTED])
freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to