On 9/15/06, Giorgos Keramidas <[EMAIL PROTECTED]> wrote:
The CVS server seems to be using some sort of CVS access control, i.e.
by a CVSROOT/readers or CVSROOT/writers file or something similar.

I didn't set anything like that up.  I simply added this line to

cvspserver stream tcp nowait   root /usr/bin/cvs cvs
--allow-root=/home/ng/tools/cvsroot --allow-root=/home/somewhere/else

I am not sure of all the gory details about your particular setup, but
the message seems to imply that `mgrant' is blocked by the access
controls of the server itself.

It sure seems that way.  Or it seems that somehow it's proposing the
wrong password.  Hmm, now, here's something funny, the password in
CVSROOT/Root is all lower case and my password is mixed case.

I tried editing this file and adding the mixed case, but no, that
didn't help.  Then, I tried changing my password on the server to
match the all lower case password it insists on putting in the Root
file and now I can get in, but only if I provide the -d :pserver:....
on the command line.  I tried setting CVSROOT but again, the same auth

Do you have a CVSROOT/readers or CVSROOT/writers in
/home/ng/tools/cvsroot/CVSROOT/ on the CVS server?

If yes, what do they contain?  Please take care of masking any sensitive
data (like user passwords), if you sent their contents!!!

No, don't have any of these files on the server.

At least I can now update my local copy from the cvs server using the
long cmd line with the -d :pserver:... stuff.  However, I'm still
curious why setting CVSROOT isn't working.

By the way, thanks for all your help.

Michael Grant
freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to