hi all,

i'm trying to copy a dos partition from one disk to another like so:

dd if=/dev/ad3s1 of=/dev/ar0s1 bs=128k

and it's failing with:

dscheck(#ar/0x20002): fixlabel: invalid magic
fixlabel: invalid magic
dd: /dev/ar0s1: Read-only file system

i'm running freebsd v4.6.2 . i'm booting from ar0s3 - i've never used ar0s1
( it's a new disk ) and i installed straight from the cd onto this disk. i
guess the install procedure may have disklabel'd it since i set the first
three slices to freebsd even though i only created partitions in ar0s3. i've
checked groups.google.com and there are two other reports of the same
problem: one person trying to zero out a slice and one trying to recover a
dos slice. both have no reported solution! also i think someone tried to
newfs_msdos and failed the same way but it's in russian so i can't quite
work it out :)


a work around appears to be using ar0 instead, e.g.:

dd if=/dev/zero of=/dev/ar0 count=10 oseek=63

which does succeed in zeroing the first ten blocks of ar0s1.


however when i then try to restore my dos slice i still get:

dd if=/dev/ad3s1 of=/dev/ar0s1
dd: /dev/ar0s1: Read-only file system

so i need to go via ar0 again:

dd if=/dev/ad3s1 of=/dev/ar0 oseek=63

which finally works :)


also, i can dd a freebsd slice without any problems, e.g.

dd if=/dev/ar0s3 of=/dev/ar0s2


my question then is, what's the 'proper' way to retrieve a slice from
freebsd's grasp? ( so that i can then get dd to work as i want it to ).

thanx,
siegfried.


To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-questions" in the body of the message

Reply via email to