I'm not trying to kick any dead horses here but there are times when I
try to run some applications that I get some messages like the following:

/libexec/ld-elf.so.1: Shared object "libc.so.5" not found, required by...

I normally reinstall compat4x or compat5x and am good to go.  I have
compat4x_enable="YES" and compat5x_enable="YES" in my /etc/rc.conf file
but I still get these messages and have to force a reinstall (after a

I just found this thread:


..and tried running the command the posted listed:

/sbin/ldconfig -m /usr/local/lib/compat

This worked like a champ.  I was able to immediately run the application
in question and didn't have to force a reinstall of compat5x.

I am sure I have missed something along the way but can someone please
assist me/point me in the right direction in getting this straightened
out so I don't have to do this manually after each reboot?  I would
greatly appreciate it.

Thanks in advance!

Jeff Cross
freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to