Oops! Addendum below:

On Tuesday, September 19, 2006 at 1:53:31 PM, Duane confabulated:

> On Tuesday, September 19, 2006 at 1:47:25 PM, Jeff confabulated:

>> Duane Hill wrote:
>>> On Tuesday, September 19, 2006 at 3:54:50 AM, Jeff confabulated:
>>>> I'm not trying to kick any dead horses here but there are times when I
>>>> try to run some applications that I get some messages like the following:
>>>> /libexec/ld-elf.so.1: Shared object "libc.so.5" not found, required by...
>>>> I normally reinstall compat4x or compat5x and am good to go.  I have
>>>> compat4x_enable="YES" and compat5x_enable="YES" in my /etc/rc.conf file
>>>> but I still get these messages and have to force a reinstall (after a
>>>> reboot).
>>>> I just found this thread:
>>>> http://unix.derkeiler.com/Mailing-Lists/FreeBSD/questions/2005-12/msg02487.html
>>>> ..and tried running the command the posted listed:
>>>> /sbin/ldconfig -m /usr/local/lib/compat
>>>> This worked like a champ.  I was able to immediately run the application
>>>> in question and didn't have to force a reinstall of compat5x.
>>>> I am sure I have missed something along the way but can someone please
>>>> assist me/point me in the right direction in getting this straightened
>>>> out so I don't have to do this manually after each reboot?  I would
>>>> greatly appreciate it.
>>> I  had to install both myself for an application we run on a server. I
>>> installed them from /usr/ports/misc/compat4x and compat5x. The install
>>> placed  the  startup  scripts  000.compat4x.sh  and 000.compat5x.sh in
>>> /usr/local/etc/rc.d.  They  startup after reboot every time. There was
>>> no need to place anything in the rc.conf.
>> That is the ports I used to install compat4x and compat5x.  However, the
>> startup scripts aren't anywhere on my system.  I searched for both using
>> locate (after updating the DB of course) and also checked in
>> /usr/local/etc/rc.d/ manually.  Nothing...

>> I update my ports tree about 2-3 times a day so I would assume I am
>> using the latest versions of the ports.  Any idea on how I can get those
>> startup scripts?  I may try a complete remove and then a fresh install.

>> I look forward to any responses.

> The only thing in the scripts is this:

>     [EMAIL PROTECTED] ~]$ cat /usr/local/etc/rc.d/000.compat4x.sh
>     #!/bin/sh
>     /sbin/ldconfig -m /usr/local/lib/compat

>     [EMAIL PROTECTED] ~]$ cat /usr/local/etc/rc.d/000.compat5x.sh
>     #!/bin/sh
>     /sbin/ldconfig -m /usr/local/lib/compat

> Why  they  have  to  both  be present, I haven't figured that out yet.
> ldconfig points both at the same location.

My  bad  on this one. The server that still has the startup scripts is
not   running   the   latest   versions.   The  versions  running  are
compat4x-i386-5.3_2 and compat5x-i386-

There  is  anther  server here that is running compat5x-i386-
and  does not have a startup script. It still works fine. I'm guessing
the other response that made mention where the startup scripts are not
needed anymore on the later version would stand correct.

"This message was sent using 100% recycled electrons."

freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to