Greg 'groggy' Lehey wrote:
On Thursday, 21 September 2006 at  7:43:44 +0300, Odhiambo Washington wrote:
* On 20/09/06 16:47 -0700, Mike Peirson wrote:
Hi all,
First off, I'm new to FreeBSD and this mailinglist so I hope I am in the
right place. Anyways, right now I am having some problems with FreeBSD
booting up. I have tried to install 3 times now and keep getting the
same error. When I try to boot into FreeBSD, this eventually comes up:

        Manual root filesystem specification:
                  <fstype>:<device> Mount <device> using filesystem
<fstype>
                                       eg. ufs:da0s1a
                  ?                 List valid disk boot devices
                  <empty line>      abort manual input
                Mountroot>

This seems to be a prompt where I need to specify the location of the
root partition, but the problem here is that it hangs or freezes and I
cannot input any text.
Any further details about your hardware specs in general?

This is a keyboard problem.  The background is that the boot process
uses a different keyboard driver from the final kernel, and that it's
much more finicky than the kernel version.  It seems to have got worse
in the last few years.  I've found that a USB keyboard will do better,
but YMMV.

At first I thought it may be a result of FreeBSD not properly
recognizing my HDD's geometry but I manually fixed that and it
still is giving me this same issue. If anyone has had a similar
problem or knows how to fix this I would greatly appreciate any
help. I looked through the Handbook and googled this but I haven't
found a solution yet.

The background for the *message* (not the apparent freeze) is that
your root file system can't be found.  This happens typically when you
change the device name.  For example, my situation is that I'm doing
development with a SATA disk drive and moving it from system to
system.  On my machine the root file system shows up as /dev/ad4s1a;
on the other machine it's /dev/ad0s1a.

It's probably worth putting in a PR about this problem.

Greg
--
See complete headers for address and phone numbers.

About the keyboard.. I have it running through a KVM switch, would this also cause any problems? I booted into safemode and noticed that the problem with inputting text was nonexistant. I am not sure why it can't find my root filesystem. I haven't changed the device name or moved anything around at all. BTW, is there any way I can get into FreeBSD (maybe via the install disc?) to get a detailed printout of my FreeBSD slice? Posting that on here may be of some use.
--
Michael Peirson
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to