Desmond Coughlan wrote:
Hi,
  I hope that I'm not sending this to the wrong list, or that the question 
hasn't already been answered.
I'm trying to install 6.1-RELEASE onto a Pentium-3. I had a lot of trouble creating the diskettes, but after changing the floppy drive, no problem. Now, when I do the install, I have two hard drives, and configure them as follows... disk0 150M / 512M /etc
  512M /etc
  512M /var
  1024M /bin
  4096M /usr
  1024M swap
disk1
  4096M /forums
  4096M /mail
  4096M /sql
  1024M swap
I go through the installation, via ftp, and then set the root password. Oh, and the 'FreeBSD boot manager' is the option I choose, when configuring the disks. When I reboot, this is what I see ... Manual root filesystem specification <fstype>:<device> Mount <device> using filesystem <fstype> eg ufs:da0s1a ? List valid disk boot devices <empty line> Abort manual imput
  ... and that's it.
Nothing else. The machine just sits there. Is there something I've missed ? We've tried the same install on three different machines, using three different motherboards, and four different hard drives. Something is wrong, either with the installation media, or else with our method of going about it. Oh, and I tried installing 5.5 on the same machines, with the same result. FreeBSD rocks; I've used it for a long time on many different machines, and this is the first time that this has happened. Could someone suggest a solution? The people with whom I'm installing this, are starting to whisper the word 'Linux', and it's giving me nightmares.... :(

Don't create a separate /bin and /etc partition, there is no need, and 512M is far sufficient for both /, /etc and /bin.

I would guess the problem is that when you boot / is mounted, but no rc script is found as it is in /etc, as well as the fstab with info on what to mount where.

Further, all the startup scripts are shell scripts and requires /bin/sh - including mountcritlocal that mounts your partions. Obviously this work because /bin is not mounted.

A common partioning would be

/
swap
/var
/usr
/home
/tmp

You want that /tmp partition because any disk errors on in /tmp are not fatal, but if it's on the / partition then you may have a system unable to boot.

Cheers, Erik
--
Ph: +34.666334818                      web: http://www.locolomo.org
X.509 Certificate: http://www.locolomo.org/crt/8D03551FFCE04F0C.crt
Key ID: 69:79:B8:2C:E3:8F:E7:BE:5D:C3:C3:B1:74:62:B8:3F:9F:1F:69:B9
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to