I tried to install FreeBSD 5.0 RC2 on a Compaq Evo D510
Convertible MiniTower and that succeeded without any problems.
However when the machine is booted after the installation I got
a "BTX halted" message.

In order to solve this I tried to find a solution in the FreeBSD
manual/FAQ and the email archives. Based on the information that
I found I tried the following things with, unfortunately, the
same result:

- A reinstall of FreeBSD 5.0 RC2 on a "Dangerously Dedicated" disk. 
- A bios upgrade from version 2.14 to 3.12
- An install of FreeBSD 4.7 Release to verify whether it was a
  problem specific to FreeBSD 5.0 RC2

Eventually I came across a solution posted by Paul Saab to
freebsd-smp on June 27th 2002, in which he recommended turning
off DMA in the BIOS, for a similar problem Craigrm of Coreix
Systems was experiencing on a Compaq Evo D500:


To see if this would also work for my Compaq Evo D510 I changed
the following setting in my BIOS:

- Storage | Device Configuration | Hard Disk | IDE Primary 0
- Changed Transfer Mode from "Max DMA" to "Max PIO"

This time FreeBSD 5.0 RC2 booted up successfully!

To see if the other DMA settings exhibited the same problem as
"Max DMA" I also tried: 
- Enhanced DMA
- Ultra DMA 0

Unfortunately they resulted in the same "BTX Halted" message upon
booting. Only "Max PIO" seems to work!

I am not sure if this is a problem on all Compaq Evo Dxxx
PCs, but at least it seems to work for the D500 and the
D510. Should this be a trouble shooting/FAQ entry?

BTW. Some one (see link below) reported that a BIOS downgrade on
his Evo 500 (D500?) from version 3.01 to version 2.06 also solved
the "BTX halted" problem. Apparently Compaq has done something
strange in the newwer versions of their BIOS' for their Compaq
Evo line of PC's. 

Only available from Google cache:|lang_en&ie=UTF-8

Anyway hope this helps other people that are trying to install
FreeBSD on a Compaq Evo Dxxx PC.


Attachment: msg14956/pgp00000.pgp
Description: PGP signature

Reply via email to