I've  got a FBSD 6 machine built from a 6.2 PRERELEASE set of sources
that I need to use as an NFS server for some other similar machines.
If I specify the machines by host name, or IP address in /etc/exports,
I can mount the requisite directories from the test client.

However, I really need to be able to allow 2 whole 1/2 class C's
to mount these directories. My reading of the /etc/exports man page 
leads me to believe that I should be able to use a line like this:

/usr/ports/distfiles       maproot=root -network aaa.bbb.ccc.0 -mask 
255.255.255.128

When I do this, and start mountd with the -d flag, I get:

ountd: getting export list
mountd: got line /usr/ports/distfiles       maproot=root -network aaa.bbb.ccc.0 
-mask
255.255.255.128mountd: making new ep fs=0x3e331e2f,0xe47d1981

But when I try to mount from a client n this network, it reports
premission denied.

I also tried putting a line like this in /etc/exports:

/usr/ports/distfiles       maproot=root -network mine

and putting the following in /etc/networks:

mine            aaa.bbb

But I still get the same error.

What am I doing wrong?


-- 
Unix is very simple, but it takes a genius to understand the simplicity.
(Dennis Ritchie)
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to