Hey all,

I've been having a problem that hopefully someone would be able to help me with. I've been trying to boot FreeBSD via PXE for at least a couple of days now with no luck. I've read several online guides none of which explain using a root mfs to accomplish this task. Most of the manuals I've read go over mounting / as NFS which isn't ideal for me.

I've got mostly everything working *up to* the point where the system begins bootstrapping. It loads the kernel, loads the mfs root and then the machine immediately reboots. For the life of me, I can't figure out why. I was hoping that someone has a documented method for initializing a FreeBSD system via PXE and without the use of NFS for the root filesystem.

For refernce my loader.rc:

echo Loading Your Kernel Fool!!!
set hint.acpi.0.disabled="1" ## have tried it without it being disabled.
load /boot/kernel/kernel
echo Loading mfs filesystem YoYo!!
load -t mfs_root /mfsroot
echo booting...
echo \007\007
set vfs.root.mountfrom=ufs:/dev/md0"    ## have tried /dev/md0c as well

wacko# ll /tftpboot/mfsroot
-rw-r--r--  1 root  wheel  4423680 Nov  2 02:33 /tftpboot/mfsroot


Assuming the mfs file sysetm is being create without error (I assume it is due to a lack of error messages), then I assume loader reads init like usual.

wacko# file /mnt/mfsroot/sbin/init
/mnt/mfsroot/sbin/init: ELF 32-bit LSB executable, Intel 80386, version 1 (FreeBSD), statically linked, stripped

And then continues on with /etc/rc....

wacko# file /mnt/mfsroot/etc/rc
/mnt/mfsroot/etc/rc: Bourne shell script text executable

As for the rest of the files....they are certainly all there.........

I believe it's also worth mentioning, that if I use the mfsroot that comes with the installer, it loads/run fine. Not sure if this helps any or not.

What could I possibly be missing?

Thanks for the time.
freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to