At 12:03 PM 1.12.2003 +0000, Matthew Seaman wrote:
>On Sat, Jan 11, 2003 at 12:01:44PM -0600, Jack L. Stone wrote:
>> At 05:44 PM 1.11.2003 +0000, Matthew Seaman wrote:
>> >On Sat, Jan 11, 2003 at 11:31:22AM -0600, Jack L. Stone wrote:
>> >> I just updated from FBSD-4.5 to 4.7 on a server running
apache_fp.1.26. The
>> >> update somehow has broken the FP extensions (ugh!). I have tried a
>> >> of fixes, including portupgrade, but get a checksum error there. Have
>> >> to rerun the present install of FP using, but get this
>> >> Who should own web root web on port 80 [www]:  
>> >> What should the group for web root web on port 80 be [www]:  
>> >> /usr/libexec/ /usr/lib/ Undefined symbol
>> >> ERROR: Unable to chown web root web in port 80
>> >> Hit enter to continue
>> >> 
>> >> I'm also seeing the "__stderrp" error in my httpd-error.log whenever
I try
>> >> to login to FP. So, something has changed in the FBSD-4.5-4.7 update and
>> >> I've never seen this error, so don't know what needs to be fixed. I have
>> >> another server running apache_fp.1.27 on FBSD.4.7 just fine.
>> >> 
>> >> It's looking like an uninstall/reinstall completely for apache+fp....
>> >> didn't want to have to do that on a box with a bunch of virtual
>> >> 
>> >> Has anyone seen the above problem on similar installs...???
>> >
>> >/usr/src/UPDATING says:
>> >
>> >20021110:
>> >        The definitions of the standard file streams (stdio, stdout, and
>> >        stderr) have changed so that they are no longer compile-time 
>> >        constants.  Some older binaries may require updated 3.X 
>> >        compatability libraries (for example, by setting COMPAT3X=yes 
>> >        for a buildworld/installworld).
>> >
>> >Alternatively to doing a buildworld with COMPAT3X=yes, you could
>> >install the misc/compat3x port.
>> Good grief! I read the UPDATING as always, but this one did NOT sink
>> in....! Thank you so much for pointing me in the right direction before I
>> shot myself in the foot....
>> If I go the misc/compat3x port route, I assume I need to redo the
>> buildword....?? If so, then I might as well include the COMPAT3X=yes in the
>> make.conf.
>All that setting COMPAT3X=yes does is cause the buildworld process to
>uudecode and install some precompiled copies of FreeBSD-3.x shared
>libraries --- see /usr/src/lib/compat/compat3x.i386 for what's
>available.  Those libraries were originally just copied off a 3.x
>machine, but since then kernel changes in 4.x or 5.0 have meant that
>certain changes have had to be back ported to RELENG_3 in order to
>maintain compatibility between the 3.x shlibs and the kernel.
>Supplying those libraries by installing the port achieves exactly the
>same effect, but quicker.  However, the choice is entirely up to you.
>In the long run, putting COMPAT3X into /etc/make.conf would be my
>choice, as my regular schedule of buildworlds would ensure everything
>was up to date.
>Once the 3.x shlibs are in place, the binary frontpage binary supplied
>with the apache-fp port should pick them up OK.  The interface between
>the 3.x shlibs and any applications linked to them should remain
>exactly the same.
>       Cheers,
>       Matthew

Matthew, thanks again for the reply. However, I've tried both methods of
the compat3x on a test server, including and whole new build/installworld
and the latest 4.7-STABLE still hoses FrontPage. I even deleted and started
from scratch on Apache+FP-1.27, but the FP install stops dead at trying to
chown the uid:gid on the root web and gives the same error:

/usr/libexec/ /usr/lib/ Undefined symbol "__stderrp"
ERROR: Unable to chown web root web in port 80

This caught me by surprise because I'd had FP running fine with FBSD-4.7
(RELEASE and STABLE) on other servers, but it was the installs JUST prior
to the change date of 20021110. In fact they where only 5 days earlier. FP
still doesn't understand what's going on apparently.

Backing down to the installs prior to 20021110 makes FP happy again.
Unfortunately, until I figure out the cure, I can't track 4.7-STABLE. As
much as it is a pain, I must run FP for the users.

No doubt others running FP must have seen this by now.... nothing else is
affected and 4.7-STABLE runs fine otherwise (tried several machines).

Any other thoughts, Matthew or from anyone much appreciated. 

Best regards,
Jack L. Stone,

SageOne Net

To Unsubscribe: send mail to [EMAIL PROTECTED]
with "unsubscribe freebsd-questions" in the body of the message

Reply via email to