Hi there,

I poked around a bit, changing several settings and the modules to be
loaded in xorg.conf. It turns out that the error is caused by DRI. I'm
pretty sure I tried this before...
So, disabling DRI by commenting out the module in xorg.conf makes X
behave correctly, I can start and stop it without any problems.

But of course I would like to use DRI on my Laptop, should give a
speed bump, especially since I'm interested in using blender.

So, is there anybody out there who could give some advice of what to do?
I changed my kernel configuration so that drm and savagedrm are part
of it, no need for a module. But this doesn't anything, too (didn't
expect it to change anything, but anyway, it was worth a try...)


On 16/11/06, Ian Smith <[EMAIL PROTECTED]> wrote:
On Wed, 15 Nov 2006, Christian Walther wrote:

 > I edited /etc/sysctl.conf and /boot/loader.conf, adding the
 > parameter/values you've given me, and rebooted the machine afterwards,
 > but it didn't change anything.

They might regarding suspend/resume video, but no, not for this one ..

 > As long as X is running, I can switch between the text consoles and X
 > without any problem. But as soon as I quit X the screen wents black
 > and is unusable until I do a cold boot.
 > I can switch to a console and start X again, thou, but the text
 > consoles remain unusable.

Sorry, I was mistaken .. I've still got this problem too.  Once I got
suspend/resume going I hadn't quit X in more than a month.  Tonight I
did, to check, and there was the blank screen again.

So I resorted to my old workaround, which may also work for you; I just
type 'fixme' at the unseen vty prompt:

t23# cat ~/bin/fixme
# strangely enough, this invalid mode restores vttyX with the error message:
# vidcontrol: cannot activate raster display: Inappropriate ioctl for device
vidcontrol VESA_800x600

Bizarre, but the only way I found worked, by accident.  Valid vidcontrol
commands failed to achieve this for me, but I know very little magic ..

Earlier I'd found that setting one vty with 'vidcontrol VGA_80x30'
before starting X helped if I switched back to that, but only running
'fixme' saved me tonight.  It's evil, but sure beats rebooting ..

 > Sorry for repeating the issue, but maybe I mislead you, because this
 > is just one problem (at least as far as I can tell). Trying to update
 > to a new BIOS version might a solution, I should check if there is
 > anything newer available.

If you have access to a windows box to burn the floppies and a USB
floppy drive, or Windows on the T23, you're set.  I have neither yet.

 > I tried several configuration up to now, there are many location where
 > you can download them. All of them had the same problem, so I'm not
 > entirely convinced that this is an X configuration issue. But could
 > you sent me your configuration, so I can give this a try? If it
 > doesn't behave as my configuration does I might be able to locate the
 > problem.

Mailed separately.  At least X hasn't crashed on me yet with that conf.

HTH, Ian

freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to