Hey,

Today I tried manually building anjuta2, after getting rid of some errors by fixing FreeBSD specific includes in the anjuta-source files At some point I got this kind of errors:


/usr/local/include/subversion-1/svn_io.h:28:17: apr.h: No such file or directory /usr/local/include/subversion-1/svn_io.h:30:25: apr_file_io.h: No such file or directory /usr/local/include/subversion-1/svn_io.h:31:29: apr_thread_proc.h: No such file or directory
In file included from /usr/local/include/subversion-1/svn_delta.h:36,
                from /usr/local/include/subversion-1/svn_wc.h:44,
                from /usr/local/include/subversion-1/svn_client.h:39,
                from svn-backend.h:25,
                from svn-backend.c:19:

So I checked the files in /usr/local/include/subversion-1/ , allmost all of them need some apr files which are included. Allthough none of them can by found when compiling the sources. When I ran a locate I found out the apr files are all in /usr/local/include/apr-1/ . I fixed the compiling errors by just symlinking the files in /usr/local/include/apr-1/ to /usr/local/include but this is just a dirty trick to fool the svn header files. Is there just an include to the apr-1 dir missing in the svn*.h files or am I missing something on my system ?

Thanks in advance,

--
-Frank Staals


_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to