Look for a package called 'expat-2.0.0'.
Once you got one look into it like this

pkg_info -L expat-2.X.tar.gz

It should then state there is a '/usr/local/lib/libexpat.so.6' in it.
If so, install it.

Nevertheless this may fail if it uses some syscall of FBSD-5.5 not
present in FBSD5.4, but i don't think so.

If all that fails, compile it yourself, like this:

cd /usr/ports/textproc/expat2
make install && make clean


I have FreeBSD-6.2 running, but without expat2. My packages
still use expat1. Simply because i built every bit from ports,
to have no braindamage with precompiled stuff wanting newest
libraries.

Looks like this on my Desktop:
----------------
[EMAIL PROTECTED] pkg_info -L /var/db/pkg/expat-1.95.8_3/
Information for expat-1.95.8_3:

Files:
/usr/local/man/man1/xmlwf.1.gz
/usr/local/bin/xmlwf
/usr/local/include/expat.h
/usr/local/include/expat_external.h
/usr/local/lib/libexpat.a
/usr/local/lib/libexpat.so
/usr/local/lib/libexpat.so.5

[EMAIL PROTECTED] ldconfig -r |grep expat
        438:-lexpat.5 => /usr/local/lib/libexpat.so.5
        680:-lexpat.4 => /usr/local/lib/libexpat.so.4
[EMAIL PROTECTED] uname -a
FreeBSD lance.net.schlund.de 6.2-PRERELEASE FreeBSD 6.2-PRERELEASE #8: Sun Nov 
12 21:59:06 CET 2006     [EMAIL PROTECTED]:/usr/src/sys/i386/compile/LANCE  i386
----------------

bye,
        Armin
-- 
PUBBOX Postmaster + spam-killer. Free email addresses at http://pubbox.net/

On Fri, Nov 24, 2006 at 09:30:39PM -0700, service wrote:
> uname -a
> FreeBSD localhost 5.4-RELEASE FreeBSD 5.4-RELEASE #0: Fri Nov 24 
> 08:54:35 UTC 2006     root@:/usr/src/sys/i386/compile/VIL  i386
> ----------------------------------------------------------------------------
> 
> I had FreeBSD-5.4 for about one and a half years.  Loading packages with 
> "pkg_add -r" was very easy.  Suddenly "pkg_add -r" no longer works.
> 
> Looking at freebsd's ftp sites, they got rid of the 5.4 release.  They 
> now have a 5.5 release.  I tried downloading from "packages-5-stable" 
> and "packages-5.5-stable".  About 50 percent of these programs fail.  I 
> get error messages that say something like  "/libexec/ld-elf.so.1: 
> Shared object "libexpat.so.6" not found".  I'm not sure, but I think 
> files ending in "so.6", belong in version 6, not version 5.  I have more 
> than 10 versions of FreeBSD.  I tried using packages off these CDs.  
> some of them worked, but most of the time I keep getting error messages.
> 
> What can I do?
> 
> Thanks in advance,
> bruce
> 
> _______________________________________________
> freebsd-questions@freebsd.org mailing list
> http://lists.freebsd.org/mailman/listinfo/freebsd-questions
> To unsubscribe, send any mail to "[EMAIL PROTECTED]"
> 
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to