On Sun, 26 Nov 2006 22:09:58 +0100
"Ralf Schreijer" <[EMAIL PROTECTED]> wrote:

> Hi there!
> Today I just installed FreeBSD(6.1) for the first time in my life.
> After several tries on my own I decided to go through the
> installation by following the instructions in the handbook. I
> successfully installed and configured Xorg. Everything went well,
> until I reached the section 5.6.2, "Using XDM". I just tried to
> follow the instructions and enabled xdm to start running on the 9th
> virtual terminal by replacing the "off" by "on" in /etc/ttys: ttyv8
> "/usr/X11R6/bin/xdm -nodaemon"  xterm   off secure in ttyv8
> "/usr/X11R6/bin/xdm -nodaemon"  xterm   on secure
> Now I can't do anything. The system directly boots into the xdm,
> prompts a loginscreen and if I login as root (or as a user) there is
> nothing I can do. As I know now there isn't even a chance to leave
> the xdm. If I hit Ctrl+Alt+Backspace, it flips into the shell an
> returns immediately to xdm and prompts the login again. I tried
> fixing this  through booting in Single User Mode, but I wasn't
> successful because I have no write permission in /etc/ttys during
> this mode.

You have just about any right in single user mode. Type
chmod 644 /etc/ttys
If you edit the file using vi and it isn't writable you can force to
write to it by typing :w!

Try to hit Ctrl+Alt+F2
This should get you to a shell.

freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to