FYI: this issue is "solved".  I applied this patch (URL below) to the
5.3sources and built a kernel with an re driver that can detect the
card.  It
seems to be working at gigabit speeds.  Out of curiosity would someone who
knows CVS better than I do kindly tell me what version of FreeBSD this patch
has been integrated to?


On 11/27/06, Scott Gasch <[EMAIL PROTECTED]> wrote:


I'm trying to get a linksys eg1032 gigabit ethernet card (version 3)
working under freebsd 5.3.  This appears to be an RTL8169S based card.

When I build a kernel with the re device (and miibus) enabled, the card is
not detected.  I also tried building a GENERIC kernel to sanity check my
config -- the card is not detected with the GENERIC kernel either.  I
verified that the if_re.c file is being compiled / included in the kernel.

The LINT config for 5.3 _does_not_ include "device re" which I find
strange.  The man page for re says it was introduced in 5.2 so I think it
should be here?

I tried disabling ACPI support in the loader menu but this did not result
in the detection of the card.

I tried booting a 6.1 kernel on the machine and it _does_ detect the
device.  Is this likely due to driver code differences or something else in
the 6.x kernels?  I'd rather not upgrade this box to 6.x yet but I could
certainly bring it up to 5.5.


_______________________________________________ mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to