I'm running 6.1-STABLE, and a few days ago cvsup'ed and tried portupgrade.

Portupgrade failed on some of xfce4's components. Checking xfce4-print and xfce4-desktop's output, I have the error message:

libicui18n.so.34, needed by /usr/local/lib/libglib-2.0.so not found (try using -rpath or -rpath-link)

So, checking for the library I first tried 'locate libicui18n.so.34' and got:

/usr/local/lib/libicui18n.so.34
/usr/local/lib/libicui18n.so.34.1

but when I ran 'find /usr/local/lib -name libicui18n.so.34' it doesn't find anything. Apparently something deleted the library since the last time 'locate' updated its database.

OK, so 'ls -l /usr/local/lib/libicui18n*' gives me:


lrwxr-xr-x 1 root wheel 18 Oct 15 18:24 libicui18n.so -> libicui18n.so.36.0 lrwxr-xr-x 1 root wheel 18 Oct 15 18:24 libicui18n.so.36 -> libicui18n.so.36.0
-r--r--r--   1 root  wheel   1474969 Oct 15 18:24 libicui18n.so.36.0


Apparently the library libicui18n.so.XX is installed by something called icu. I don't know what it is, but the latest version is icu-36, and it installed libicui18n.so.36.0, made links to it, and may have deleted libicui18n.so.34 at the same time. Should I try creating a link named 'libicui18n.so.34' to 'libicui18n.so.36.0'?

One problem I have is that I don't understand the suggestion in the error message, "try using -rpath or -rpath-link", and Google isn't helping me.

--
Roger


_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to