Pablo Mora wrote:
On 12/1/06, Laszlo Nagy <[EMAIL PROTECTED]> wrote:
What am I going wrong? Please help!

System: FreeBSD 6.1-RELEASE-p10 #4: Thu Nov 30 13:33:49 CET 2006
The ports tree was updated yesterday, then I ran

portupgrade -a

It was completed today. Then I ran "portinstall gnome2" and got this error:

grep: /usr/X11R6/lib/libgnomeui-2.la: No such file or directory
sed: /usr/X11R6/lib/libgnomeui-2.la: No such file or directory
gnome-libtool: link: `/usr/X11R6/lib/libgnomeui-2.la' is not a valid
libtool archive
gmake[2]: *** [libeel-2.la] Error 1
gmake[2]: Leaving directory
`/usr/ports/x11-toolkits/eel/work/eel-2.16.3/eel'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/usr/ports/x11-toolkits/eel/work/eel-2.16.3'
gmake: *** [all] Error 2
*** Error code 2

Stop in /usr/ports/x11-toolkits/eel.

NOTE: The correct file is in /usr/local/lib/libgnomeui-2.la, but the
port cannot find it.


20061014:
 AFFECTS: All GTK+2 and GNOME users
 AUTHOR: [EMAIL PROTECTED]

 GNOME has been updated to 2.16. All GTK+2 and GNOME components have
 been moved from X11BASE (/usr/X11R6) to LOCALBASE (/usr/local). To
 upgrade your GNOME desktop or/and other applications you will need
 to use either sysutils/portupgrade or sysutils/portmaster. To use
 portmaster, make sure you have least 1.9 version to have the
 upgrade succeed.

Portupgrade users:
 pkgdb -Ff
 portupgrade -rf pkg-config\*
I did this, but I still get the same error.

The strange thing is that after running "portupgrade -rf pkg-config\*", I tried to run it again and it started to upgrade everything again. I think this is bad.

  Laszlo

_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to