Hello Brian and welcome!

On Tue, 12 Dec 2006 21:38:19 -0000 Brian Levie wrote:

> I recently installed FreeBSD  6.1,

How did you do it?

> and copied many Unix files with no

What do you call "Unix files" and where did you get them?

> problems at all.  However when I try to run the C compiler which worked fine
> with Unix, I get the error message '/usr/bin/cc Exec format error  Binary
> file not executable'. I tried changing permissions and owner with no change.

Please, show us the output of commands "uname -a", "file /usr/bin/cc"
and "ls -l /usr/bin/cc".

> Any suggestions or won't the unix C compiler not work with FreeBSD?

Well, FreeBSD is used to be compiled by this compiler. Those troubles
of yours shouldn't happen. ;-)

Boris Samorodov (bsam)
Research Engineer, http://www.ipt.ru Telephone & Internet SP
FreeBSD committer, http://www.FreeBSD.org The Power To Serve
freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to