El domingo 17 de diciembre a las 21:53:00 CET, Greg Groth escribió:
> Beech Rintoul wrote:
> >On Sunday 17 December 2006 07:31, Greg Groth wrote:
> >>I'm attempting to update Audacious without much luck.  Last time I ran
> >>into this issue, I simply had to do a make deinstall / make install, and
> >>it worked fine.  This time, I'm unable to deinstall the old version.
> >>When running make deinstall from the ports directory I get:
> >>
> >>===>  Deinstalling for multimedia/audacious
> >>===>   audacious-1.1.2 has a different PREFIX: /usr/X11R6, skipping
> >>
> >>Any ideas on how I can deinstall this port?  I checked
> >>/usr/ports/UPDATING, but didn't seem to find anything (unless I made a
> >>typo in my text search).
> >
> >Portupgrade or portmaster are your friends.
> It failed with portmanager, so I tried portupgrade to see what the 
> problem was.  When I ran portupgrade, I got the following:
> Note: Configure has discovered that you already have Audacious installed
> and it does not match with the given --prefix. You have Audacious 
> installed in /usr/X11R6/bin and you chose /usr/local/bin.
> If you don't want two copies of Audacious installed, rerun configure 
> with the --prefix option set to the location of the old Audacious, or 
> uninstall the old Audacious.
> After compiling for a bit, it exited with the following error:
> playlist.c: In function `playlist_entry_get_info':
> playlist.c:181: error: structure has no member named `mtime'

> [ ............... ]
> Stop in /usr/ports/multimedia/audacious.
> ** Command failed [exit code 1]: /usr/bin/script -qa 
> /tmp/portupgrade.81965.0 env UPGRADE_TOOL=portupgrade 
> UPGRADE_PORT=audacious-1.1.2 UPGRADE_PORT_VER=1.1.2 make
> ** Fix the problem and try again.
> I think I had similar issues in the past when I tried to update 
> Audacious, and a make deinstall / make install clean fixed the problem. 
>  This is when I attempted to deinstall Audacious, and was unable to. 
> I've never tried portmaster, but I'm thinking it only works if you 
> install from packages (please correct me if I'm wrong), and I have 
> everything compiled from source.  Any ideas?

I had exactly the same problem as you. IMHO, it should be reported to
the mantainer as a problem report.

Look at the thread:



Attachment: pgplV8PA9cmpN.pgp
Description: PGP signature

Reply via email to