Hi All,

I installed PC-BSD 1.2 (FreeBSD 6.1-RELEASE-p2) on a PC with i810
chipset. Well, as you might have guessed from the subject, X did not
start, with an error indicating the /dev/agpgart was not present.

AFAIK, agp, drm support is built-in for FreeBSD 6.1 - so I am not sure
why /dev/agpgart was not created. Other similar threads did not help
much, as the solutions involved creating the node by hand (which I
think won't work), or adding some patch to the kernel (not sure if
this will work either, as the support is built-in). As a sidenote,
Ubuntu 6.06 on the same machine properly created /dev/agpgart, and
things are fine.

I tried doing "X -config", which gave me a crude 640x480 resolution.
In the Device section, giving module to be i810 or vesa did not help
either. The same error persists.

Any pointers to get X working shall be appreciated. I do not have an
access to this machine, so cannot really post the errors or log files.
Also, since PC-BSD uses FreeBSD 6.1, I thought of posting here. Thanks
in advance.

freebsd-questions@freebsd.org mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to