> -----Original Message-----
> From: [EMAIL PROTECTED] 
> [mailto:[EMAIL PROTECTED] On Behalf Of Vizion
> Sent: Monday, January 01, 2007 9:08 AM
> To: freebsd-questions@freebsd.org
> Cc: [EMAIL PROTECTED]
> Subject: Re: mozilla - bind conflict _
> 
> 
> 
> 
> > -----Original Message-----
> > From: Beech Rintoul [mailto:[EMAIL PROTECTED] 
> > Sent: Monday, January 01, 2007 8:49 AM
> > To: Vizion
> > Cc: freebsd-questions@freebsd.org
> > Subject: Re: mozilla - bind conflict _
> > 
> > 
> > On Monday 01 January 2007 07:39, Vizion wrote:
> > > > -----Original Message-----
> > > > From: [EMAIL PROTECTED]
> > > > [mailto:[EMAIL PROTECTED] On Behalf Of
> > > > Beech Rintoul
> > > > Sent: Monday, January 01, 2007 7:08 AM
> > > > To: freebsd-questions@freebsd.org
> > > > Cc: Vizion
> > > > Subject: Re: mozilla - bind conflict _
> > > >
> > > > On Monday 01 January 2007 03:00, Vizion wrote:
> > > > > Hi
> > > > >
> > > > > I am having problems upgrading mozilla-1.7.13,2 ro
> > > >
> > > > mozilla-1.7.13_1,2
> > > >
> > > > > (www/mozilla)
> > > > >
> > > > > Build fails
> > > > > mozilla-1.7..13_1,2: bind installed with
> > > >
> > > > PORT_REPLACES_BASE_BIND causes
> > > >
> > > > > problems.
> > > > >
> > > > > I first recompiled bind9 without this option but got the
> > > >
> > > > same failure.
> > > >
> > > > > Then I deinstalled bind9 entirely and retried the 
> > portupgrade after
> > > > > portsclean -C only to get the same failure.
> > > > >
> > > > > Suggestions please
> > > > >
> > > > > Thanks
> > > > > david
> > > >
> > > > If you have a bind line in your /etc/make.config
> > > > (PORT_REPLACES_BASE_BIND9)
> > > > remove it. Alternately, you can do a "make -k" to override
> > > > the error, but if
> > > > you do that keep a close eye on your build to make sure you
> > > > don't have an
> > > > error somewhere else that gets ignored.
> > > >
> > > > Beech
> > >
> > > Thanks -- I should have mentioned that I had checked 
> > make.config as I had
> > > the same idea..I am now wondering where the &*^% the system 
> > is getting the
> > > idea that PORT_REPLACES_BASE_BIND is valid for bind... 
> > puzzled ignorance
> > > reins supreme here.
> > 
> > CD to the bind9 directory and do a "make config." That is 
> > also an option that 
> > you need to uncheck. I had the same problem with several 
> > ports and finally 
> > went back to the dist version.
> > 
> > Beech
> 
> Thanks for sticking with me on this - but, assuming you mean 
> /usr/ports/dns/bind9 I tried that one too.. ensuring the line
> REPLACE_BASE was unchecked and did the same for all other 
> bind versions in ports/dns. 
> 
> I have now tried a system shutdown in case the 
> PORT_REPLACES_BASE_BIND option is stored dynamically but to 
> no avail. I still get the error message:
> mozilla-1.7..13_1,2: bind installed with 
> PORT_REPLACES_BASE_BIND causes problems.
> 
> This is becoming a witch hunt to locate the broomstick!! <chuckles>
> 
> David

Just to add latest info -- here are the error messages.. one can also  see that 
an attempt to deinstall the current version fails...

I do not know whether this makes any sense to anyone else but I am getting 
nowehere with it <resigned smiley>
=> MD5 Checksum OK for mozilla-1.7.13-source.tar.bz2.
=> SHA256 Checksum OK for mozilla-1.7.13-source.tar.bz2.
=> MD5 Checksum OK for libart_lgpl-1.tar.bz2.
=> SHA256 Checksum OK for libart_lgpl-1.tar.bz2.
===>   mozilla-1.7.13_1,2 depends on file: /usr/local/bin/perl5.8.8 - found
===>  Patching for mozilla-1.7.13_1,2
===>   mozilla-1.7.13_1,2 depends on file: /usr/local/bin/perl5.8.8 - found
===>  Applying extra 
patch /usr/ports/www/mozilla/files/extra-patch2-nsSVGLibartGlyphMetricsFT.cpp
===>  Applying FreeBSD patches for mozilla-1.7.13_1,2
mozilla-1.7.13_1,2: bind installed with PORT_REPLACES_BASE_BIND causes build 
problems.
*** Error code 1

Stop in /usr/ports/www/mozilla.
** Command failed [exit code 1]: /usr/bin/script -qa /tmp/portupgrade.3595.0 
env UPGRADE_TOOL=portupgrade UPGRADE_PORT=mozilla-1.7.13,2 
UPGRADE_PORT_VER=1.7.13,2 make
** Fix the problem and try again.
** Listing the failed packages (*:skipped / !:failed)
        ! www/mozilla (mozilla-1.7.13,2)        (unknown build error)
--->  Packages processed: 0 done, 0 ignored, 0 skipped and 1 failed
[EMAIL PROTECTED] /usr/ports/www/mozilla]# make deinstall
===>  Deinstalling for www/mozilla
===>   mozilla-1.7.13,2 has a different PREFIX: /usr/X11R6, skipping

david


_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to