Greetings:

The System here:
FreeBSD 6.1-RELEASE-p10 FreeBSD 6.1-RELEASE-p10 #2

I "portupgrade -rR kde" which upgraded kde properly from 3.5.1 to 3.5.5
(It took 4 days!)

Then I did "portupgrade koffice"

Here is the error:

================

if /bin/sh /usr/local/bin/libtool --silent --tag=CXX --mode=compile c++
-DHAVE_CONFIG_H -I. -I. -I../../.. -I. -I../../../lib/kofficeui
-I../../../lib/kofficeui -I../../../lib/kofficecore
-I../../../lib/kofficecore -I../../../lib/store -I../../../lib/store
-I../../../lib/kwmf -I../../../lib/kwmf -I../../../lib/kopalette
-I../../../lib/kopalette -I/usr/local/include
-I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include
-I/usr/local/include/libxml2 -I/usr/local/include
-I/usr/X11R6/include/libgsf-1 -L/usr/local/lib -liconv
-I/usr/local/include -I/usr/X11R6/include  -I/usr/local/include
-D_THREAD_SAFE -pthread -DQT_THREAD_SUPPORT -I/usr/local/include
-D_THREAD_SAFE   -Wno-long-long -Wundef -Wall -W -Wpointer-arith
-DNDEBUG -DNO_DEBUG -O2 -O2 -march=pentiumpro -Wno-non-virtual-dtor
-fno-exceptions -fno-check-new -fno-common -DQT_CLEAN_NAMESPACE
-DQT_NO_ASCII_CAST -DQT_NO_STL -DQT_NO_COMPAT -DQT_NO_TRANSLATION
-DHAVE_KNEWSTUFF  -MT graphicshandler.lo -MD -MP -MF
".deps/graphicshandler.Tpo" -c -o graphicshandler.lo
graphicshandler.cpp; \ then mv -f ".deps/graphicshandler.Tpo"
".deps/graphicshandler.Plo"; else rm -f ".deps/graphicshandler.Tpo";
exit 1; fi

In file included from /usr/local/include/wv2/olestream.h:22,
                 from graphicshandler.cpp:23:

/usr/local/include/wv2/olestorage.h:26:21: gsf/gsf.h: No such file or
directory

In file included from /usr/local/include/wv2/olestream.h:22,
                 from graphicshandler.cpp:23:

/usr/local/include/wv2/olestorage.h:165: error: ISO C++ forbids
declaration of `GsfInfile' with no type


/usr/local/include/wv2/olestorage.h:165: error: expected `;' before '*'
token

/usr/local/include/wv2/olestorage.h:166: error: ISO C++ forbids
declaration of `GsfOutfile' with no type

/usr/local/include/wv2/olestorage.h:166: error: expected `;' before '*'
token

/usr/local/include/wv2/olestorage.h:175: error: expected `)' before '*'
token

/usr/local/include/wv2/olestorage.h:176: error: expected `)' before '*'
token

/usr/local/include/wv2/olestorage.h:178: error: ISO C++ forbids
declaration of `GsfInfile' with no type

/usr/local/include/wv2/olestorage.h:178: error: expected `;' before '*'
token

/usr/local/include/wv2/olestorage.h:179: error: ISO C++ forbids
declaration of `GsfOutfile' with no type

/usr/local/include/wv2/olestorage.h:179: error: expected `;' before '*'
token

In file included from graphicshandler.cpp:23:

/usr/local/include/wv2/olestream.h:87: error: expected `)' before '*'
token

/usr/local/include/wv2/olestream.h:153: error: ISO C++ forbids
declaration of `GsfInput' with no type

/usr/local/include/wv2/olestream.h:153: error: expected `;' before '*'
token

/usr/local/include/wv2/olestream.h:160: error: expected `)' before '*'
token

/usr/local/include/wv2/olestream.h:221: error: ISO C++ forbids
declaration of `GsfOutput' with no type

/usr/local/include/wv2/olestream.h:221: error: expected `;' before '*'
token

gmake[4]: *** [graphicshandler.lo] Error 1

gmake[4]: Leaving directory
`/usr/ports/editors/koffice-kde3/work/koffice-1.6.1/filters/kword/msword'

gmake[3]: *** [all-recursive] Error 1

gmake[3]: Leaving directory
`/usr/ports/editors/koffice-kde3/work/koffice-1.6.1/filters/kword'

gmake[2]: *** [all-recursive] Error 1

gmake[2]: Leaving directory
`/usr/ports/editors/koffice-kde3/work/koffice-1.6.1/filters'

gmake[1]: *** [all-recursive] Error 1

gmake[1]: Leaving directory
`/usr/ports/editors/koffice-kde3/work/koffice-1.6.1'

gmake: *** [all] Error 2

*** Error code 2

Stop in /usr/ports/editors/koffice-kde3.
** Command failed [exit code 1]: /usr/bin/script
-qa /tmp/portupgrade.79788.0 make ** Fix the problem and try again.
** Listing the failed packages (*:skipped / !:failed)
        ! editors/koffice-kde3 (koffice-1.4.2_3,1)      (missing header)
--->  Packages processed: 0 done, 0 ignored, 0 skipped and 1 failed

========================

Currently installed wv2-0.2.3

Any help would be appreciated

Best Regards
Bob
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to