Thank you for your quick answer.

Changing the setting in the sshd_config file enabled sshd root login (naturally). Shhd-problem solved :)

Apache is still not working very well, there are no errors in any of the logs, neither in /var/log/* nor the /usr/local/apache2/logs/*

Someone said it might not be working because it's listening on IPv6, and suggested that I enabled IPv4. How is that done?

running "ipfw -a l" returned a "ipfw: getsockopt(IP_FW_GET): Protocol not available", whatever that means.




At 13:43 16.01.2003 +0100, you wrote:

If you try to conncet for sshd with user root, look at /etc/ssh/sshd_config for, by default PermitRootLogin is NO:

#LoginGraceTime 120
PermitRootLogin no <- if you want to connect as root user change to yes and try again
#StrictModes yes

Look what you have in:
tail -f /var/log/messages
tail -f /var/log/httpd-error.log
when you try to connect to httpd

AND check with ipfw that not have firewall settings in your mashine:"ipfw -a l"


Vegard Skjefstad wrote:
I'm unable to connect to my EPIA-800 box running FreeBSD 5.0 RC-3. Connecting to servers FROM the box (for instance browsing the web with lynx) and ping works just find.

I'm running 2.0.43 of Apache, not sure what version of sshd, I run the one that came with FreeBSD. Both daemons are up and running, and listening to their ports, at least according to sockstat. httpd is listening to port 80 (using tcp6 only, of some reason), while sshd is listening on port 22 (both tcp4 and tcp6). I've also got inetd running, if I open for telnet in the /etc/inted.conf file, I'm able to telnet from another machine and connect to the box. A solution might be to add sshd and httpd in inetd, but from what I've heard, inetd is listening for connections to certain ports, then, if any connections are detected, opening the appropriate program and routing the connection to that program (am I right on this one?). This should not be necessary, since both sshd and httpd is already listening for connections on their own.

My first assumption was that the problem was caused by a firewall, but I don't think any firewall or firewall rules are set up, since firewall_enable="NO" in the /etc/defaults/rc.conf.

Another fishy thing is that I'm also unable to connect to Apache from localhost using lynx. "lynx 192.168.0.10:80" gives me an "Alert!: Unable to connect to remote host.". The ServerName is set to 192.168.0.10:80 in the httpd.cond file. Connecting to the sshd using ssh works "fine" in the sense that I get a connection to sshd, but is unable to log in

Pinging the FreeBSD system from another computer works fine.

So, do you guys have any ideas? Good or bad, it doesn't matter, because I'm totally out of ideas...

(and if you guessed I was pretty new at this, you guessed right )

<mailto:[EMAIL PROTECTED]>[EMAIL PROTECTED]
http://www.vegard.net/
ICQ UIN: 11872166
MSN: <mailto:[EMAIL PROTECTED]>[EMAIL PROTECTED]
Yahoo! ID: jebusde
AIM: vegardskjefstad





---
This mail is certified Virus Free.
Checked by AVG anti-virus system (<http://www.grisoft.com>http://www.grisoft.com).
Version: 6.0.443 / Virus Database: 248 - Release Date: 10.01.2003


[EMAIL PROTECTED]
http://www.vegard.net/
ICQ UIN: 11872166
MSN: [EMAIL PROTECTED]
Yahoo! ID: jebusde
Jabber: [EMAIL PROTECTED]
---
This mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.443 / Virus Database: 248 - Release Date: 10.01.2003


Reply via email to