Hello all,

I've been upgrading my FreeBSD system into a fully-fledged desktop
system.

zsh as installed (from the port) seems only to recognize the /etc/zshenv
startup file.  And I needed an stty command to get proper backspace/delete
behavior.  Because only the /etc/zshenv file seemed to be recognized,
I had to put the stty command in it.

The stty command works fine, but unsurprisingly produces an error in my
automated jobs that ssh into the system.  So I tried:

if [ ${TERM} ]
then
        stty erase "^?"
fi

That didn't work, so I tried:

if [ -n ${TERM} ]
then
        stty erase "^?"
fi

Someone who actually knows what they're doing will, I'm sure, instantly
recognize the problem with this.  I'm pretty sure TERM is indeed the
variable I should be testing, but that I'm not testing it in the right  
way.

What is the magic way?

-- 
David Benfell, LCP
[EMAIL PROTECTED]
---
Resume available at http://www.parts-unknown.org/
NOTE: I sign all messages with GnuPG (0DD1D1E3).

Attachment: pgpkIiK4dbhQn.pgp
Description: PGP signature

Reply via email to