The problem is likely the that you don't have the full path to stty in your script, and the automated jobs don't have a proper path set yet. Use the full pathname in your script and see if that works.


At 04:37 PM 1/29/2007, David Benfell wrote:
Hello all,

I've been upgrading my FreeBSD system into a fully-fledged desktop

zsh as installed (from the port) seems only to recognize the /etc/zshenv
startup file.  And I needed an stty command to get proper backspace/delete
behavior.  Because only the /etc/zshenv file seemed to be recognized,
I had to put the stty command in it.

The stty command works fine, but unsurprisingly produces an error in my
automated jobs that ssh into the system.  So I tried:

if [ ${TERM} ]
        stty erase "^?"

That didn't work, so I tried:

if [ -n ${TERM} ]
        stty erase "^?"

Someone who actually knows what they're doing will, I'm sure, instantly
recognize the problem with this.  I'm pretty sure TERM is indeed the
variable I should be testing, but that I'm not testing it in the right

What is the magic way?

David Benfell, LCP
Resume available at
NOTE: I sign all messages with GnuPG (0DD1D1E3).

This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.
MailScanner thanks transtec Computers for their support.

_______________________________________________ mailing list
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to