Greetings all,

Problem with maintaining the internet connection: on startup I do:

# ppp -ddial internet

and all is well. It may be 2 days, it may be one hour later I fail to
connect to mail and internet. When I check the connection using:

$ bash-2.05b$ netstat -rn
Routing tables

Internet:
Destination        Gateway            Flags    Refs      Use  Netif Expire
default               202.64.10.27       UGS        0    18028   tun0
127.0.0.1          127.0.0.1              UH          0      441     lo0
202.64.10.27    210.17.143.28      UH          1        0       tun0

So all would still appear to be OK, but nevertheless I get no mail and no
connection to a web page. OK, I redo ppp -ddial internet, and I get the
following netstat -rn printout:

bash-2.05b$ netstat -rn
Routing tables

Internet:
Destination         Gateway               Flags    Refs      Use  Netif
Expire
default                202.64.10.32         UGS         0    18090   tun1
127.0.0.1            127.0.0.1                UH          0      441     lo0
202.64.10.27       210.17.143.28       UH          0        0      tun0
202.64.10.32       210.17.197.153      UH          1        0      tun1


And all works for a while, but ..... stops. So I reboot, and all works like
a charm.

Checking /var/log/ppp.log I see episodes of this:

Feb  7 12:18:17  ppp[9716]: Warning: iface add: ioctl(SIOCAIFADDR,
210.17.198.175 -> 202.64.10.32): File exists
Feb  7 12:18:17  ppp[9716]: Error: ipcp_InterfaceUp: unable to set ip
address
Feb  7 12:18:32  ppp[9716]: Phase: bundle: Terminate
Feb  7 12:18:32  ppp[9716]: Phase: deflink: open -> lcp
Feb  7 12:18:32  ppp[9716]: Phase: deflink: Disconnected!
Feb  7 12:18:32  ppp[9716]: Phase: deflink: lcp -> logout
Feb  7 12:18:32  ppp[9716]: Phase: deflink: logout -> hangup
Feb  7 12:18:32  ppp[9716]: Phase: deflink: Disconnected!

But reconnecting gives this output:

Feb  7 13:53:08  ppp[1292]: Phase: Using interface: tun1
Feb  7 13:53:08  ppp[1292]: Phase: deflink: Created in closed state
Feb  7 13:53:30  ppp[1357]: Phase: PPP Started (ddial mode).
Feb  7 13:53:30  ppp[1357]: Phase: bundle: Establish
Feb  7 13:53:30  ppp[1357]: Phase: deflink: closed -> opening
Feb  7 13:53:30  ppp[1357]: Phase: deflink: Connected!
Feb  7 13:53:30  ppp[1357]: Phase: deflink: opening -> dial
Feb  7 13:53:30  ppp[1357]: Phase: deflink: dial -> carrier
Feb  7 13:53:31  ppp[1357]: Phase: Received NGM_PPPOE_ACNAME (hook
"VTA23-1-RX")
Feb  7 13:53:31  ppp[1357]: Phase: Received NGM_PPPOE_SESSIONID
Feb  7 13:53:31  ppp[1357]: Phase: Received NGM_PPPOE_SUCCESS
Feb  7 13:53:31  ppp[1357]: Phase: deflink: carrier -> login
Feb  7 13:53:31  ppp[1357]: Phase: deflink: login -> lcp
Feb  7 13:53:32  ppp[1357]: Warning: deflink: Reducing configured MRU from
1500 to 1492
Feb  7 13:53:32  ppp[1357]: Phase: bundle: Authenticate
Feb  7 13:53:32  ppp[1357]: Phase: deflink: his = PAP, mine = none
Feb  7 13:53:32  ppp[1357]: Phase: Pap Output: [EMAIL PROTECTED] ********
Feb  7 13:53:32  ppp[1357]: Phase: Pap Input: SUCCESS ()
Feb  7 13:53:32  ppp[1357]: Phase: deflink: lcp -> open
Feb  7 13:53:32  ppp[1357]: Phase: bundle: Network
Feb  7 13:53:32  ppp[1357]: Phase: deflink: IPV6CP protocol reject closes
IPV6CP !


1. What are the possible causes?
2. Why does the routing table still show an active connection?
3. What steps could I take in troubleshooting?

Sadly, the FreeBSD handbook and FreeBSD Unleashed do not have the answers,
and google is rather dry on the subject.

In hope

Brian
_______________________________________________
freebsd-questions@freebsd.org mailing list
http://lists.freebsd.org/mailman/listinfo/freebsd-questions
To unsubscribe, send any mail to "[EMAIL PROTECTED]"

Reply via email to